YAFLogo

Pyroto
  • Pyroto
  • 51.2% (Neutral)
  • YAF Forumling Topic Starter
13 years ago
I searched the forum, but did not see an answer that fit my issue.

I tried to upgrade to 1.9.3

The install/upgrade went fine - I was told that it was successful.

However, when the install page redirected me to the home page, I received the following error:

The control with ID '' requires a ScriptManager on the page. The ScriptManager must appear before any controls that need it.

I am using plain vanilla latest version of YAF that I downloaded from the site this evening (Yet Another Forum.NET Version 1.9.3 April 23, 2009).

I have tried all of the various web.config incarnations found in the \webconfigs directory, without modification.

I'm not sure what to do now.

Suggestions?

Thanks.

James

Sponsor

herman_herman
13 years ago
Make sure you have Ajax 1.0 extension installed.
Pyroto
  • Pyroto
  • 51.2% (Neutral)
  • YAF Forumling Topic Starter
13 years ago
Thank-you for the suggestion. Unfortunately, installing the Ajax 1.0 extensions did not solve the problem.
herman_herman
13 years ago
add a reference to "System.web.extension.dll" and see if it compiles!
mr3xcellent
13 years ago
I'm having the same issue... Pyroto, have you resolved this?

I'm very new to YAF, and I'm trying to upgrade from 1.9.1.8. I've run the upgrade, and it said it finished, but when I try to load the forums I get the same error as Pyroto.

Setup:

Windows Server 2008 SP1

IIS7

I have ASP.NET AJAX Extensions 1.0 installed.

My "forums/" folder is setup as an application running .NET 2.0.

I'm not sure what info is needed to diagnose, but here's my web.config anyway. Thanks in advance...

sangheraajit
13 years ago
Is any one sovle this issue

i m also facing same issue.

mr3xcellent
13 years ago
I was running the wrong version... I downloaded YAF-v1.9.3-FINAL-BIN-NET35.zip (becuase initailly I wanted the .NET 3.5 version), but when I decided to run in .NET 2.0, I forgot.

I then downloaded the YAF-v1.9.3-FINAL-BIN-NET20.zip, which seems to have resolved THIS issue.

I ran into some other issues before this one, which I mentioned here .