YAFLogo

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.1
2021-10-31T08:22:02Z
I checked the upgrade package but everthing is fine. Are You sure you updated all dlls in the bin folder? Otherwise i have no more ideas.
UserPostedImage
cbirchy87
  • cbirchy87
  • 62.6% (Friendly)
  • YAF Forumling Topic Starter
2021-10-31T12:12:54Z
I deleted thd bin folder and used the one included in the upgrade pack. Issue appears to be with the login dialog. 
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.1
2021-10-31T13:13:46Z
And did you also extract all other files from the zip package and copy them over to your site? 

I did the same process and it works without problems.


UserPostedImage
cbirchy87
  • cbirchy87
  • 62.6% (Friendly)
  • YAF Forumling Topic Starter
2021-10-31T14:18:27Z
I did. I removed the folders in the guide then moved everything from that upgrade zip over. Overwriting everything. 

I guess I will give it another go

cbirchy87
  • cbirchy87
  • 62.6% (Friendly)
  • YAF Forumling Topic Starter
2021-10-31T23:34:12Z
Just to confirm

1. Delete the folders in the guide

2. marge the Web. config OR use the recommended web. config in the new configs folder. 

3. copy ALL files and folders over to FTP overwriting ALL files

4. Ensure the web.config is the merged copy of the one stored in the new config folder

5. go to www.{forumURL}/install

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.1
2021-11-01T01:06:06Z
Originally Posted by: cbirchy87 

Just to confirm

1. Delete the folders in the guide

2. marge the Web. config OR use the recommended web. config in the new configs folder. 

3. copy ALL files and folders over to FTP overwriting ALL files

4. Ensure the web.config is the merged copy of the one stored in the new config folder

5. go to www.{forumURL}/install

Yes that's correct. Did yaf run as standalone application or inside another application?


UserPostedImage
cbirchy87
  • cbirchy87
  • 62.6% (Friendly)
  • YAF Forumling Topic Starter
2021-11-01T07:12:07Z
Depolyed to a Azure webapp via FTP. 

The database is from 2.2.2. Ideally, I want to be on the latest version. Is there another way to do the upgrade rather than having to install 2.2.2 and follow the info? I will try a clean 2.2.2 install (as a test) and run the upgrade to see if I still have any issues. 

Is it not possible to install a new version of v3 and use the 2.2.2 database? 

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.1
2021-11-01T08:18:07Z
Yes of course you can also upgrade to version 3.0. But I don't know if this would solve the problem.
UserPostedImage
cbirchy87
  • cbirchy87
  • 62.6% (Friendly)
  • YAF Forumling Topic Starter
2021-11-01T09:06:26Z
I have created a new 2.2.2 install with a new database, and that was fine with an update to 2.3.1

If i was in a situation where I only had the database, what process would I follow to get a new 2.2.2 running with my datatabase?

cbirchy87
  • cbirchy87
  • 62.6% (Friendly)
  • YAF Forumling Topic Starter
2021-11-01T09:40:05Z
Ah!

Done :)

Looks like we had some issues without 2.2.2 files. Started a new 2.2.2 and linked to db. the upgrade went perfectly! Thanks for the great support 🙂