YAFLogo

RyeRocks
  • RyeRocks
  • 53% (Neutral)
  • YAF Forumling Topic Starter
6 years ago
Hi. New to the YAF forum and software - and a bit new to web development as well, so bear with me.

I've developed a site, but have not yet published it. I am looking to have a page on my website with a forum for members and was hoping to add YAF to my visual studio solution, but I'm not sure how to do it. As far as I know visual studio has a built in IIS, so the installation instructions for YAF confuse me a bit.

Has anyone done this, or know what I'm talking about haha. Appreciate any advice or assistance anyone can provide, thanks.

Sponsor

Zero2Cool
6 years ago
I believe this would be a great starting point for you.

https://github.com/YAFNET/YAF.SampleWebApplication 

RyeRocks
  • RyeRocks
  • 53% (Neutral)
  • YAF Forumling Topic Starter
6 years ago
I D/L'd the sample app, and was trying to figure out how to hook up the DB. Is there an mdf or bak file I can attach/restore to my sql server express? I haven't found the db yet to make it work.
Zero2Cool
6 years ago
Originally Posted by: RyeRocks 

I D/L'd the sample app, and was trying to figure out how to hook up the DB. Is there an mdf or bak file I can attach/restore to my sql server express? I haven't found the db yet to make it work.

You have to create a database, then enter the the necessary values in your connection string. The connection string can be found in db.config

RyeRocks
  • RyeRocks
  • 53% (Neutral)
  • YAF Forumling Topic Starter
6 years ago
Ok, thanks. And where do I get the details on table names and column names? Apologies if this is documented somewhere, but I haven't seen it yet.
Zero2Cool
6 years ago
Originally Posted by: RyeRocks 

Ok, thanks. And where do I get the details on table names and column names? Apologies if this is documented somewhere, but I haven't seen it yet.

When you navigate to your forum after you've added the connection string, you'll be put into the Install/Setup Wizard and that will create the tables for you.

RyeRocks
  • RyeRocks
  • 53% (Neutral)
  • YAF Forumling Topic Starter
6 years ago
Sweet. Will give it a try this afternoon.
RyeRocks
  • RyeRocks
  • 53% (Neutral)
  • YAF Forumling Topic Starter
6 years ago
Getting an error: Could not find stored procedure 'dbo.yaf_registry_list'.

I guess the connection is working to get this far? Any thoughts? I'm running the webpage called "Default" - is that correct?