YAFLogo

Jayhawk
  • Jayhawk
  • 61.4% (Friendly)
  • YAF Camper Topic Starter
8 years ago
I am a newbie to Yaf.net, but like what I see. I just installed the new 2.0 version locally, it works great! But installing it on Azure, I was getting the exact same error message that started this thread. I turned off custom error in web.config and now it says

Invalid object name 'sysfiles'.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Data.SqlClient.SqlException: Invalid object name 'sysfiles'.

I tried changing it to sys.sysfiles to be more specific but got exactly the same error.

Again, I am a newbie here, very green and would appreciate some help.

.

Sponsor

Jaben
  • Jaben
  • 100% (Exalted)
  • YAF Developer
8 years ago
The wiki has a topic on setup with azure:

https://github.com/YAFNET/YAFNET/wiki 

The membership has to be setup specially on Azure:

https://github.com/YAFNET/YAFNET/wiki/Install-YAF-with-Windows-SQL-Azure 

deggen40
8 years ago
It appears that the scripts to setup membership have disappeared. Does anyone know where I can get them?
Eagle_f90
8 years ago
Originally Posted by: deggen40 

It appears that the scripts to setup membership have disappeared. Does anyone know where I can get them?

I am having the same problem. Are there any updated install instructions for Azure? The membership scripts are missing from the link and it would be nice if we did not have to compleatly setup a local SQL install then migrate to Azure.