YAFLogo

spamflame
  • spamflame
  • 50.6% (Neutral)
  • YAF Forumling Topic Starter
10 years ago
I've done all the preparation for istallation (using YAF instal. manual). Config was checked.

Then I tried to launch the installation file.

There is an error:

Quote:

Could not load file or assembly 'System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e' or one of its dependencies. The system cannot find the file specified.

I try to install YAF version 1.9.5 RC1. There is no CMS, forum is located in a sub-folder.

Here is the trace:

Quote:

[FileNotFoundException: Could not load file or assembly 'System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e' or one of its dependencies. The system cannot find the file specified.]

System.ModuleHandle.ResolveType(RuntimeModule module, Int32 typeToken, IntPtr* typeInstArgs, Int32 typeInstCount, IntPtr* methodInstArgs, Int32 methodInstCount, ObjectHandleOnStack type) +0

System.ModuleHandle.ResolveTypeHandleInternal(RuntimeModule module, Int32 typeToken, RuntimeTypeHandle[] typeInstantiationContext, RuntimeTypeHandle[] methodInstantiationContext) +180

System.Reflection.RuntimeModule.ResolveType(Int32 metadataToken, Type[] genericTypeArguments, Type[] genericMethodArguments) +192

System.Reflection.CustomAttribute.FilterCustomAttributeRecord(CustomAttributeRecord caRecord, MetadataImport scope, Assembly& lastAptcaOkAssembly, RuntimeModule decoratedModule, MetadataToken decoratedToken, RuntimeType attributeFilterType, Boolean mustBeInheritable, Object[] attributes, IList derivedAttributes, RuntimeType& attributeType, IRuntimeMethodInfo& ctor, Boolean& ctorHasParameters, Boolean& isVarArg) +115

System.Reflection.CustomAttribute.GetCustomAttributes(RuntimeModule decoratedModule, Int32 decoratedMetadataToken, Int32 pcaCount, RuntimeType attributeFilterType, Boolean mustBeInheritable, IList derivedAttributes, Boolean isDecoratedTargetSecurityTransparent) +426

System.Reflection.CustomAttribute.GetCustomAttributes(RuntimeAssembly assembly, RuntimeType caType) +103

System.Reflection.RuntimeAssembly.GetCustomAttributes(Boolean inherit) +33

System.Web.UI.AssemblyCache.GetAjaxFrameworkAssemblyAttribute(Assembly assembly) +76

System.Web.UI.ScriptManager.get_DefaultAjaxFrameworkAssembly() +399

System.Web.UI.ScriptManager..ctor() +26

ASP.forum_install_default_aspx.__BuildControlScriptManager1() +25

ASP.forum_install_default_aspx.__BuildControlForm1() +133

ASP.forum_install_default_aspx.__BuildControlTree(forum_install_default_aspx __ctrl) +201

ASP.forum_install_default_aspx.FrameworkInitialize() +44

System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +54

System.Web.UI.Page.ProcessRequest() +78

System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context) +21

System.Web.UI.Page.ProcessRequest(HttpContext context) +49

ASP.forum_install_default_aspx.ProcessRequest(HttpContext context) +4

System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +100

System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +75

I searched the internet and there was no result. Do you have any ideas how to fix it? 😞

Sponsor
squirrel
10 years ago
Originally Posted by: spamflame 

I've done all the preparation for istallation (using YAF instal. manual). Config was checked.

Then I tried to launch the installation file.

There is an error:

Quote:

Could not load file or assembly 'System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e' or one of its dependencies. The system cannot find the file specified.

I try to install YAF version 1.9.5 RC1. There is no CMS, forum is located in a sub-folder.

Here is the trace:

Quote:

[FileNotFoundException: Could not load file or assembly 'System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e' or one of its dependencies. The system cannot find the file specified.]

System.ModuleHandle.ResolveType(RuntimeModule module, Int32 typeToken, IntPtr* typeInstArgs, Int32 typeInstCount, IntPtr* methodInstArgs, Int32 methodInstCount, ObjectHandleOnStack type) +0

System.ModuleHandle.ResolveTypeHandleInternal(RuntimeModule module, Int32 typeToken, RuntimeTypeHandle[] typeInstantiationContext, RuntimeTypeHandle[] methodInstantiationContext) +180

System.Reflection.RuntimeModule.ResolveType(Int32 metadataToken, Type[] genericTypeArguments, Type[] genericMethodArguments) +192

System.Reflection.CustomAttribute.FilterCustomAttributeRecord(CustomAttributeRecord caRecord, MetadataImport scope, Assembly& lastAptcaOkAssembly, RuntimeModule decoratedModule, MetadataToken decoratedToken, RuntimeType attributeFilterType, Boolean mustBeInheritable, Object[] attributes, IList derivedAttributes, RuntimeType& attributeType, IRuntimeMethodInfo& ctor, Boolean& ctorHasParameters, Boolean& isVarArg) +115

System.Reflection.CustomAttribute.GetCustomAttributes(RuntimeModule decoratedModule, Int32 decoratedMetadataToken, Int32 pcaCount, RuntimeType attributeFilterType, Boolean mustBeInheritable, IList derivedAttributes, Boolean isDecoratedTargetSecurityTransparent) +426

System.Reflection.CustomAttribute.GetCustomAttributes(RuntimeAssembly assembly, RuntimeType caType) +103

System.Reflection.RuntimeAssembly.GetCustomAttributes(Boolean inherit) +33

System.Web.UI.AssemblyCache.GetAjaxFrameworkAssemblyAttribute(Assembly assembly) +76

System.Web.UI.ScriptManager.get_DefaultAjaxFrameworkAssembly() +399

System.Web.UI.ScriptManager..ctor() +26

ASP.forum_install_default_aspx.__BuildControlScriptManager1() +25

ASP.forum_install_default_aspx.__BuildControlForm1() +133

ASP.forum_install_default_aspx.__BuildControlTree(forum_install_default_aspx __ctrl) +201

ASP.forum_install_default_aspx.FrameworkInitialize() +44

System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +54

System.Web.UI.Page.ProcessRequest() +78

System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context) +21

System.Web.UI.Page.ProcessRequest(HttpContext context) +49

ASP.forum_install_default_aspx.ProcessRequest(HttpContext context) +4

System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +100

System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +75

I searched the internet and there was no result. Do you have any ideas how to fix it? :(

1.9.5 RC1 is very old version. Recommend use latest version (1.9.6.1) on ASP.NET 4.0 capable server.

That appears to be a core ASP.NET error but I do not recognize it.


If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend