YAFLogo

Thantis
  • Thantis
  • 81.8% (Honored)
  • YAF Commander Topic Starter
10 years ago
Hey all,

So I upgraded to 1.9.6 RC1 and I'm having a sporadic problem. Some times when

I try to enter users in the admin panel I run into the 2 errors below (from yaf's logs).

Other times, I can enter the users panel just fine. Any ideas?

.Net SqlClient Data Provider

Invalid column name 'Birthday'.

Invalid column name 'Birthday'.

Invalid column name 'Birthday'.

ASP.default_aspx

System.ArgumentOutOfRangeException: The added or subtracted value results in an un-representable DateTime.

Parameter name: t

at System.DateTime.op_Addition(DateTime d, TimeSpan t)

at YAF.Core.Services.YafDateTime.FormatDateTime(DateTime dateTime)

at YAF.Pages.Admin.users.InitSinceDropdown()

at YAF.Pages.Admin.users.Page_Load(Object sender, EventArgs e)

at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)

at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)

at System.EventHandler.Invoke(Object sender, EventArgs e)

at System.Web.UI.Control.OnLoad(EventArgs e)

at System.Web.UI.Control.LoadRecursive()

at System.Web.UI.Control.LoadRecursive()

at System.Web.UI.Control.LoadRecursive()

at System.Web.UI.Control.LoadRecursive()

at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Sponsor
bbobb
  • bbobb
  • 100% (Exalted)
  • YAF Developer
10 years ago
Save a user's profile to fix the first problem. Everyone should make it after upgrade.
Thantis
  • Thantis
  • 81.8% (Honored)
  • YAF Commander Topic Starter
10 years ago
Well, saving the profiles does seem to have fixed the birthday error, but I still get the error below when

I try to enter the users tab. Odd thing is, if I restart the app pool (restart the app/save web_config) the problem

goes away for a little while. The solution is only temporary though, an hour or two later I can't enter the users

page in the admin panel again. (See error below)

System.ArgumentOutOfRangeException: The added or subtracted value results in an un-representable DateTime.

Parameter name: t

at System.DateTime.op_Addition(DateTime d, TimeSpan t)

at YAF.Core.Services.YafDateTime.FormatDateTime(DateTime dateTime)

at YAF.Pages.Admin.users.InitSinceDropdown()

at YAF.Pages.Admin.users.Page_Load(Object sender, EventArgs e)

at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)

at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)

at System.EventHandler.Invoke(Object sender, EventArgs e)

at System.Web.UI.Control.OnLoad(EventArgs e)

at System.Web.UI.Control.LoadRecursive()

at System.Web.UI.Control.LoadRecursive()

at System.Web.UI.Control.LoadRecursive()

at System.Web.UI.Control.LoadRecursive()

at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

bbobb
  • bbobb
  • 100% (Exalted)
  • YAF Developer
10 years ago
I can't reproduce it. Delete YAF browser cookie and see what happens The incorrect value is stored in your session..

Thantis
  • Thantis
  • 81.8% (Honored)
  • YAF Commander Topic Starter
10 years ago
Mmm, clearing the cookies didn't help. I've disabled the custom errors and I will see if I get a more detailed error that way, and post that when it comes up again. The sporadic nature of this has me scratching my head.
Thantis
  • Thantis
  • 81.8% (Honored)
  • YAF Commander Topic Starter
10 years ago
Well, the errors are the same from both. Any other ideas to try?
Thantis
  • Thantis
  • 81.8% (Honored)
  • YAF Commander Topic Starter
10 years ago
After a little more research this error only seems to occur when I have logged into the forum from two seperate computers. If I only use one computer the error doesn't appear, as soon as I log in on another pc it starts again.
bbobb
  • bbobb
  • 100% (Exalted)
  • YAF Developer
10 years ago
Something horrible detected again in the latest repository on the front page.

UserPostedImage

It seems that it's connected with URL rewriting logic.

Thantis
  • Thantis
  • 81.8% (Honored)
  • YAF Commander Topic Starter
10 years ago
Thanks Bbobb, at least I know I'm not crazy! I'll keep an eye out for a fix.
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
10 years ago
Originally Posted by: Thantis 

After a little more research this error only seems to occur when I have logged into the forum from two seperate computers. If I only use one computer the error doesn't appear, as soon as I log in on another pc it starts again.

Looks like this was a very rare issue, but i was able to reproduce it. It should be fixed now in the repository.

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
10 years ago
Originally Posted by: bbobb 

Something horrible detected again in the latest repository on the front page.

It seems that it's connected with URL rewriting logic.

I see the same db calls with or without rewriting enabled. The user_list sp calls come from the UserLink

string displayName = this.Get<IUserDisplayName>().GetName(this.UserID);