YAFLogo

JTGrime
  • JTGrime
  • 53.6% (Neutral)
  • YAF Forumling Topic Starter
10 years ago
Hi all,

My forum is running its fine with one exception, the notify moderators on new post dosen't appears to be working even though the option is selected in the admin CP. I have looked at the .config files responsible for mail distribution etc and they seem to be configured correctly, So without being able to step through (which I can't) I'm at a loss with whats up.

cheers for any help

Sponsor
JTGrime
  • JTGrime
  • 53.6% (Neutral)
  • YAF Forumling Topic Starter
10 years ago
BUMP, Any help guys n gals?
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
10 years ago
Quote:

My forum is running its fine with one exception, the notify moderators on new post dosen't appears to be working even though the option is selected in the admin CP

Which Option are you meaning exactly? Because there is no such function to notify Moderators about new Posts. There is only an Option where users can decide if there want to get an Notification. Unfortunately That Notification Feature has never working Properly

JTGrime
  • JTGrime
  • 53.6% (Neutral)
  • YAF Forumling Topic Starter
10 years ago
Pre-moderated:

If the forum is moderated, posts have to be approved by a moderator

it was more this functionality tbh I have tested it myself with two separate users of appropriate privileges for its functionality, And I have not had any notifications when logged in as a mod as to weather a post needs approval or not, is this the functionality you are referring to which hasn't worked properly or do you mean something else?

Thanks for the feedback so far, much appreciated.

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
10 years ago
Quote:

which hasn't worked properly or do you mean something else?

No i meant the Auto Watch Topic Feature.

Ok so you mean this Setting "Email Moderators On New Moderated Post". Tested and works with latest code.

Quote:

And I have not had any notifications when logged in as a mod as to weather a post needs approval or not,

The Account you have tested this is this also an Admin Account? Looks like admins not correctly flagged as Mods. Only The Users That are listed in the Moderator Column (On the Forum list) or that are listed as Moderators on the Team Page will receive an Email Notification.

JTGrime
  • JTGrime
  • 53.6% (Neutral)
  • YAF Forumling Topic Starter
10 years ago
no I created a catagory to test and two users of different privlidge i.e. myMod and MySubUser and performed the test using these controls.

cheers,

p.s. web.config appears to be config as intended.