YAFLogo

cheekykevwalker
11 years ago
I am getting the following error after I have added a poll to my YAF forum.

'Object cannot be cast from DBNull to other types'

Does anyone have any ideas what the reason for this might be?

Many thanks

Kevin

Sponsor

bbobb
  • bbobb
  • 100% (Exalted)
  • YAF Developer
11 years ago
They don't have paranormal skills to figure out YAF version and FULL error info from the YAF log.

So no chance at all to get an answer. 🙂

cheekykevwalker
11 years ago
Hi,

The version is 1.9.5.5 RTW

Where might I find the log files you mention, and I will post them?

Thanks

bbobb
  • bbobb
  • 100% (Exalted)
  • YAF Developer
11 years ago
I can't repeat it. Discribe how you're created the poll and look for an error log entry in admin sections.
cheekykevwalker
11 years ago
I am unsure where the error logs are created. In the admin section it is not recording this error at all.

Below is the full detail od the ASP.NET error:

[InvalidCastException: Object cannot be cast from DBNull to other types.]

System.DBNull.System.IConvertible.ToInt32(IFormatProvider provider) +57

System.Convert.ToInt32(Object value) +28

YAF.controls.PollList.BindData() +1363

YAF.controls.PollList.Page_Load(Object sender, EventArgs e) +552

System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +14

System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +46

System.Web.UI.Control.OnLoad(EventArgs e) +83

System.Web.UI.Control.LoadRecursive() +120

System.Web.UI.Control.LoadRecursive() +190

System.Web.UI.Control.LoadRecursive() +190

System.Web.UI.Control.LoadRecursive() +190

System.Web.UI.Control.LoadRecursive() +190

System.Web.UI.Control.LoadRecursive() +190

System.Web.UI.Control.LoadRecursive() +190

System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3959

cheekykevwalker
11 years ago
To create the poll I check [add poll] when I create a new topic. This presents the lists of questions, I add 2 sample questions and click save.
bbobb
  • bbobb
  • 100% (Exalted)
  • YAF Developer
11 years ago
Originally Posted by: cheekykevwalker 

To create the poll I check [add poll] when I create a new topic. This presents the lists of questions, I add 2 sample questions and click save.

Just created a new topic, checked poll option, added a question and 2 answers; no othe options added like bound etc. and saved. Added the second poll. No errors too.

I use the latest svn, but the core poll functionality was not chaged since 1.9.5.5 RTW to give out the error like this..

I can't help you.

Did you upgrade it or was it a clean install?

cheekykevwalker
11 years ago
This was a clean install. Thanks for your help on this anyway. I must be missing something.