YAFLogo

CarmillaBat
  • CarmillaBat
  • 51.2% (Neutral)
  • YAF Forumling Topic Starter
11 years ago
Hi,

I'm new to YAF and I'm trying to get the installation to work. I've gotten past a lot of obstacles, but I don't know what to do about this. Here's the error message:

Server Error in '/' Application.


Invalid language file \\10.0.0.10\vol100\content\84\107484\forum.sfx-ingenjor.se\public_html\DesktopModules\YetAnotherForumDotNet\languages\english.xml

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.ApplicationException: Invalid language file \\10.0.0.10\vol100\content\84\107484\forum.sfx-ingenjor.se\public_html\DesktopModules\YetAnotherForumDotNet\languages\english.xml

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[ApplicationException: Invalid language file \\10.0.0.10\vol100\content\84\107484\forum.sfx-ingenjor.se\public_html\DesktopModules\YetAnotherForumDotNet\languages\english.xml]

YAF.Classes.Core.Localizer.LoadFile() +712

YAF.Classes.Core.Localizer..ctor(String fileName) +45

YAF.Classes.Core.YafLocalization.LoadTranslation(String fileName) +373

YAF.Classes.Core.StaticDataHelper.TimeZones(String forceLanguage) +28

YAF.Install._default.Page_Load(Object sender, EventArgs e) +480

System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +14

System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +35

System.Web.UI.Control.OnLoad(EventArgs e) +91

System.Web.UI.Control.LoadRecursive() +74

System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2207

I would be grateful for any help!

/Ulla

Sponsor

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
11 years ago
Which Version did you use? Did you download the files from this site?
CarmillaBat
  • CarmillaBat
  • 51.2% (Neutral)
  • YAF Forumling Topic Starter
11 years ago
I used 1.9.4 which I downloaded from Source Forge.
rooq
  • rooq
  • 52.4% (Neutral)
  • YAF Forumling
5 years ago
i found this was due to the install looking for the language folder in the incorrect path

so instead of looking at

c:/mywebsite/forum/languages

it was looking at

c:/mywebsite/forum/forum/languages

I couldnt see where this path was being defined so I ended up changing the directory structure to match what the install was using.

This resolved the error for me.