YAFLogo

QumyRanson1
  • QumyRanson1
  • 61% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.1.8
11 months ago
Hi
Sorry I came back with another problem. I tried to edit one of my subforums and got an error: Cannot have multiple items selected in a DropDownList.
I have upgraded to 3.1.8.This happens when i edit old subforums. If I create new one there will be no error.
In my event log I see multiples errors:

Quote:

Exception of type 'System.Web.HttpUnhandledException' was thrown. 127.0.0.1
http://localhost:50165/Default.aspx?g=admin_EditForum&fa=62 System.WebException of type 'System.Web.HttpUnhandledException' was thrown.
at System.Web.UI.Page.HandleError(Exception e)
at System.Web.UI.Page.d__523.MoveNext()
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at System.Web.Util.WithinCancellableCallbackTaskAwaitable.WithinCancellableCallbackTaskAwaiter.GetResult()
at System.Web.UI.Page.d__515.MoveNext()
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at System.Web.UI.Page.d__554.MoveNext()
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at System.Web.TaskAsyncHelper.EndTask(IAsyncResult ar)
at ASP.default_aspx.EndProcessRequest(IAsyncResult ar) in c:'Users'User'AppData'Local'Temp'Temporary ASP.NET Files'vs'2f1e9005'91079704'App_Web_tmi2hj4j.2.cs:line 0
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStepImpl(IExecutionStep step)
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)



Any help please?
Thanks

Also One more question: is it safe to delete stored procedures?

Ā 
Sponsor

QumyRanson1
  • QumyRanson1
  • 61% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.1.8
11 months ago
Sorry I forgot to attach the screenshot:

 Screenshot.jpg You have insufficient rights to see the content.
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead šŸ¤“ YAF Version: 3.0.3
11 months ago
I think i found the issue. Can you check if it was fixed in 3.1.9?

Quote:

Also One more question: is it safe to delete stored procedures?

Ā 

Yaf dont use any sp. So yes its safe to delete a sp
QumyRanson1
  • QumyRanson1
  • 61% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.1.8
11 months ago
Sorry but same problem and same error. I think the problem is related to the parent forum dropdown.

 Screenshot2.png You have insufficient rights to see the content.

When i select "None" from the list, it works and redirects to localhost:50165/Admin/Forums but if i revert back to the original parent forum the page just flashes and nothing happens.
The error I mentioned earlier only happens if I change any of the dropdowns inside "Access Masks" !
QumyRanson1
  • QumyRanson1
  • 61% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.1.8
11 months ago
Any help please?
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead šŸ¤“ YAF Version: 3.0.3
11 months ago
Originally Posted by: QumyRanson1 

Sorry but same problem and same error. I think the problem is related to the parent forum dropdown.

 Screenshot2.png You have insufficient rights to see the content.

When i select "None" from the list, it works and redirects to localhost:50165/Admin/Forums but if i revert back to the original parent forum the page just flashes and nothing happens.



I assume that this is a different issue? Is this browser specific, if yes which browser is used?

Originally Posted by: QumyRanson1 


The error I mentioned earlier only happens if I change any of the dropdowns inside "Access Masks" !



Thanks for that info. i might found the issue of this, this would be fixed with the next release.
QumyRanson1
  • QumyRanson1
  • 61% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.1.8
11 months ago
Hello and thanks for your reply,
I will test with different browser and report back asap.
QumyRanson1
  • QumyRanson1
  • 61% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.1.8
11 months ago
Hi
The problem is not related to browsers.I testes Opera, Edge and Firefox.
I noticed that if I change the parent forum to anything other than the original one,I can save it but if I select the original parent forum it does not save and the page just flashes!
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead šŸ¤“ YAF Version: 3.0.3
11 months ago
Are there any JavaScript errors in the Browser console after the page flashes?
QumyRanson1
  • QumyRanson1
  • 61% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.1.8
11 months ago
I am afraid I dont know where to check for šŸ™„
Do you mean the log section?
Sorry not that technical šŸ˜
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead šŸ¤“ YAF Version: 3.0.3
11 months ago
No Problem. I mean the browser console inside the Browser. You can open it via F12 on most browsers. More info here..,.

https://appuals.com/open-browser-console/ 

If there are any java script issue, then there should be issues in red.
QumyRanson1
  • QumyRanson1
  • 61% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.1.8
11 months ago
Hi
I had hard time figuring out how to look for errors šŸ˜‚.
I only see this error in console:

Uncaught TypeError: $.notify is not a function
    ShowPopupDialogNotificationforum_YafForumPageErrorPopup1 http://localhost:50165/Admin/EditForum?fa=60:482
    fpModal http://localhost:50165/Admin/EditForum?fa=60:483
    getHandler http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:3484
    Sys$_Application$raiseLoad http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:4978
    Sys$_Application$initialize http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:4950
    init http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:5038
    check http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:5049
    Sys$_Application$_domReady http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:5047
    Sys$_Application http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:4720
    <anonymous> http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:5123
EditForum:482:3

Thanks

Edit: I also found several other occasions where similar error is shown (Useful tool 😉)

ban a user:
Uncaught TypeError: $.notify is not a function
    ShowPopupDialogNotificationforum_YafForumPageErrorPopup1 http://localhost:50165/Admin/EditUser?u=295:1663
    fpModal http://localhost:50165/Admin/EditUser?u=295:1666
    getHandler http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:3484
    Sys$_Application$raiseLoad http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:4978
    Sys$_Application$initialize http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:4950
    init http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:5038
    check http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:5049
EditUser:1663:3

Reindex or shrink database:
Uncaught TypeError: $.notify is not a function
    ShowPopupDialogNotificationforum_YafForumPageErrorPopup1 http://localhost:50165/Admin/ReIndex:249
    fpModal http://localhost:50165/Admin/ReIndex:250
    getHandler http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:3484
    Sys$_Application$raiseLoad http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:4978
    Sys$_Application$initialize http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:4950
    init http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:5038
    check http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:5049
    Sys$_Application$_domReady http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:5047
    Sys$_Application http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:4720
    <anonymous> http://localhost:50165/ScriptResource.axd?d=D9drwtSJ4hBA6O8UhT6CQt1yg-5YBYkKxcQC4xQjUHXO04u0uNI57pDlmV35R_qNGdVlgq60hYZ9O0od4Hk3KSoYFHyNz2E5NIpswEguGNFX0bpAN_B-Yh1w-auHLcRL8LzZb_Oy0T1M0TF5Z10L4NH4DXg1jU28ABWBo2iFk8E1&t=49337fe8:5123
ReIndex:249:3

Whenever i try to post or edit:
GEThttp://localhost:50165/content/jquery.fileupload.comb.css
[HTTP/1.1 404 Not Found 213ms]

And maybe other places I have not checked.

Thank you
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead šŸ¤“ YAF Version: 3.0.3
11 months ago
Thanks for the info. iĀ  found the issue. Issue will be fixed in 3.1.10
QumyRanson1
  • QumyRanson1
  • 61% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.1.8
11 months ago
Thank you. Any ETA on 3.1.10?
QumyRanson1
  • QumyRanson1
  • 61% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.1.8
11 months ago
Hi
Happy new year.Thanks for updating yaf.
But unfortunately I have faced another issue with the new version.I get an error saying something about child forum.I have not changed any thing.I just click edit and the save button.

 Screenshot 2023-01-01 at 14-58-54 Add_Edit Forum Ā· Art Techno Forum.png You have insufficient rights to see the content.
YAF Logo Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved
About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button