YAFLogo

universesolved
a year ago
Hi, I am running YAF 1.9.1.2 on a Windows server hosted by GoDaddy. They had upgraded the IIS version last year and I recently noticed that, since then, there have been no new registrants in my forum. So I tested it by attempting to register with a different email address. The problem turned out to be that when I received my verification email, the URL string was non-secure, as shown below. Clicking on the link results in a "Site can't be reached page". When I replaced "http" with "https", everything was fine, but my users won't think to do that. Is there a URL string definition somewhere where I can stick the "s" in? (Note: the web.config file does have a redirect rule, but for some reason it doesn't work in this case)

Thanks very much!

You have requested to join Programmed Reality, but before you can join your email address must be verified.

To verify your email address open the following link in your web browser:

hidden>>

Your approval key is:

<hidden>

http://theuniversesolved.com:443/yetanotherforum/default.aspx?g=forum 

Sponsor

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead ūü§ī YAF Version: 3.0.3
a year ago
The base url mask can be set in the board settings, that is used for email links.

However you should set a rewrite rule to automatically redirect all http to https

https://ca.godaddy.com/help/redirect-my-website-to-https-in-windows-hosting-27873 

universesolved
a year ago
Hello, thanks very much for your quick response.

I don't think the URL mask can be set in Board Settings in version 1.9.1.2. I'm attempting to upload a screen shot.

I had also tried that exact code snippet that you pointed me to, both in the web.config file at the root of the server, at one level above the YAF directory (my domain level), and at the YAF directory level. In the latter case, it seemed to break the Forum access so I took it out. In the other two instances, there was no change in behavior.

 board settings.png You have insufficient rights to see the content.

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead ūü§ī YAF Version: 3.0.3
a year ago
Quote:

. In the latter case, it seemed to break the Forum access so I took it out. In the other two instances, there was no change in behavior.

What is the problem? Atleast on my test installation the rewrite setting works

theuniversesolved
9 months ago
Hi, I am replying from a new account, "theuniversesolved", as my old account "universesolved", is now inaccessible for some reason.  I know it has been a long time, but this problem has never gotten fixed.  I'll attached the error that I get when attempting to access the Forum after making the change that you suggested.  I'm happy to provide much more detail around the site, the web.config files, etc.  Alternatively, I'm very happy to pay someone to actually fix the problem.  Any help is greatly appreciated.

 Screen Shot 2021-01-08 at 9.55.30 AM.png You have insufficient rights to see the content.

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead ūü§ī YAF Version: 3.0.3
9 months ago
the old account has been restored.

Regarding the error message. The errror message is very clear. The folder of your forum is not setup as application in your iis server.

theuniversesolved
9 months ago
Thank you, but it must be set up as an application because everything works fine except the issue of the email registration link that is missing the "s".  That's all I am trying to fix.  When I included the recommended code snippet to fix that problem, that's when I got the error message that I sent a week ago.  This is the full web.config file...

 

   

   

 

 

 

 

   

   

   

     

   

   

   

   

 

 

   

   

     

      -->

     

   

   

     

     

     

     

    -->

Again, the forum works fine except for the non-secure link sent in a registration email.  So, per the instructions in the link that you sent me, I inserted the following snippet just before the closing system.webserver tag...

That is when it broke and gave me the error message that I sent.  So I took the snippet back out.  People use my forum but all new users that attempt to join can not join because of the wrong URL they are sent.  Any further help would be greatly appreciated.  Thanks much.

Cheers

theuniversesolved
9 months ago
ok, it seems that i can't embed the code in this window so i am attaching a screen capture of the web.config

 webconfig.png You have insufficient rights to see the content.

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead ūü§ī YAF Version: 3.0.3
9 months ago
do you have multiple web.config files? Are you running the forum in the folder yetanotherforum as separate application or inside the main application?

You need to modify the web.config in the folder theuniversesolved