YAFLogo

Virko85
  • Virko85
  • 51.2% (Neutral)
  • YAF Forumling Topic Starter
11 years ago
I upgraded the forum on my test server to 1.9.5.5 and ran into a few strange issues. I am hosting yaf on a windows server 2008 R2 web edition server set to use .net 3.5 sp1.

The first problem is anytime i post a topic i get an error and the following event is logged:

System.InvalidOperationException: Sequence contains no elements

at System.Linq.Enumerable.First[TSource](IEnumerable`1 source)

at YAF.Pages.posts.BindData()

at YAF.Pages.posts.Page_Load(Object sender, EventArgs e)

at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)

at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)

at System.EventHandler.Invoke(Object sender, EventArgs e)

at System.Web.UI.Control.OnLoad(EventArgs e)

at System.Web.UI.Control.LoadRecursive()

at System.Web.UI.Control.LoadRecursive()

at System.Web.UI.Control.LoadRecursive()

at System.Web.UI.Control.LoadRecursive()

at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Second i use a custom tool bar but when i set YAF.ShowToolBar to false i get errors when the page tries to do a post back such as when i open the shourt box or it tries to refresh the shout box or i click new post. The error in the log is as follows:

System.Web.HttpException: Failed to load viewstate. The control tree into which viewstate is being loaded must match the control tree that was used to save viewstate during the previous request. For example, when adding controls dynamically, the controls added during a post-back must match the type and position of the controls added during the initial request.

at System.Web.UI.Control.LoadViewStateRecursive(Object savedState)

at System.Web.UI.Control.LoadChildViewStateByIndex(ArrayList childState)

at System.Web.UI.Control.LoadViewStateRecursive(Object savedState)

at System.Web.UI.Control.LoadChildViewStateByIndex(ArrayList childState)

at System.Web.UI.Control.LoadViewStateRecursive(Object savedState)

at System.Web.UI.Control.LoadChildViewStateByIndex(ArrayList childState)

at System.Web.UI.Control.LoadViewStateRecursive(Object savedState)

at System.Web.UI.Page.LoadAllState()

at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

I did notice others were having an issue with this as well and it is slated to be fixed in 1.9.5.6 but i figured id include it with the rest.

The last thing i have noticed is that even though i have the board set to use google for jquery apis when i do a view source it is referencing a local folder, however in all of the admin pages it uses google. Also i changed the YAF.JQueryUILangFile and YAF.JQueryUIFile to use https however for some reason it still doesnt use the settings in the app.config and still goes to gools http site and i constantly get security warnings in the admin pages if i am using IE.

Any help is greatly appreciated.

Sponsor

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
11 years ago
Quote:

Second i use a custom tool bar but when i set YAF.ShowToolBar to false i get errors when the page tries to do a post back such as when i open the shourt box or it tries to refresh the shout box or i click new post

Confirmed, its a bug. Fixed in SVN # 4890.

This will be fixed in 1.9.5.6, also the other error.

Quote:

The last thing i have noticed is that even though i have the board set to use google for jquery apis when i do a view source it is referencing a local folder, however in all of the admin pages it uses google. Also i changed the YAF.JQueryUILangFile and YAF.JQueryUIFile to use https however for some reason it still doesnt use the settings in the app.config and still goes to gools http site and i constantly get security warnings in the admin pages if i am using IE.

Use YAF.JQueryUILang and YAF.JQueryUI instead of YAF.JQueryUILangFile and YAF.JQueryUIFile

this will be correct in 1.9.5.6