cagliostro
2010-09-02T10:27:28Z
Hello.

After a week or so for my new installation, i only see two same errors in the event log. Personally i didn't experience any problem using YAF, since right only me is using it.

Here is the error:

YAF.YafResourceHandler

System.IO.IOException: The process cannot access the file 'C:\HostingSpaces\2008R2\domain.zzzz\wwwroot\images\noCover.png' because it is being used by another process.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy)
at System.IO.FileStream..ctor(String path, FileMode mode)
at YAF.YafResourceHandler.GetAlbumCover(HttpContext context)

Any ideas on what this could be ?

Thanks
Sponsor
tha_watcha
2010-09-02T11:41:23Z
Its happening when two or more users access the file at the same time. It needs to be loaded in File Sharing Mode. Issue will be fixed :cheesy:
UserPostedImage

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved