xnera
  •  xnera
  • 51.8% (Neutral)
  • YAF Forumling Topic Starter
2009-09-10T19:29:07Z
I am not sure what to do about this. I set up the forums successfully on my local server for testing.
Now copied to hosting at godaddy and was able to do the initial setup OK, tables are all set up in the DB etc.
I can create a new forum and category, but I cannot create an access mask, or register a new user. I get the following error:


Security Exception
Description: The application attempted to perform an operation not allowed by the security policy. To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file.

Exception Details: System.Security.SecurityException: Request for the permission of type 'System.Security.Permissions.FileIOPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:


[SecurityException: Request for the permission of type 'System.Security.Permissions.FileIOPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.]
System.Security.CodeAccessSecurityEngine.Check(Object demand, StackCrawlMark& stackMark, Boolean isPermSet) +0
System.Security.CodeAccessPermission.Demand() +58
System.Reflection.Assembly.VerifyCodeBaseDiscovery(String codeBase) +118
System.Reflection.Assembly.get_CodeBase() +35
System.Web.Handlers.ScriptResourceHandler.GetCodeBaseWithAssert(Assembly assembly) +31
System.Web.Handlers.ScriptResourceHandler.GetLastWriteTime(Assembly assembly) +36
System.Web.Handlers.ScriptResourceHandler.GetAssemblyInfoInternal(Assembly assembly) +61
System.Web.Handlers.ScriptResourceHandler.GetAssemblyInfo(Assembly assembly) +62
System.Web.Handlers.RuntimeScriptResourceHandler.System.Web.Handlers.IScriptResourceHandler.GetScriptResourceUrl(Assembly assembly, String resourceName, CultureInfo culture, Boolean zip, Boolean notifyScriptLoaded) +325
System.Web.Handlers.ScriptResourceHandler.GetScriptResourceUrl(Assembly assembly, String resourceName, CultureInfo culture, Boolean zip, Boolean notifyScriptLoaded) +33
System.Web.UI.ScriptManager.GetScriptResourceUrl(String resourceName, Assembly assembly) +89
System.Web.UI.ScriptRegistrationManager.RegisterClientScriptResource(Control control, Type type, String resourceName) +111
System.Web.UI.ScriptManager.RegisterClientScriptResource(Control control, Type type, String resourceName) +9


Sponsor
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer
xnera
  •  xnera
  • 51.8% (Neutral)
  • YAF Forumling Topic Starter
2009-09-11T09:53:33Z
Well I did Google it and did not find anything useful, so I was hoping someone here would have a solution.

I wrote to GoDaddy support to see if they could offer up any solution.

However, the weird thing is now suddenly it works. I have not done anything to the site since last night when it wasn't working and I posted this message. I had tried it a few times from a few different browsers. Now today it works. Not sure what changed.
devvvy
  •  devvvy
  • 52.4% (Neutral)
  • YAF Forumling
2009-10-18T07:30:40Z
I run into exact same problem - all good on my dev server but just don't cut it after deployed to 1and1 (my hosting provider)

I believe 1and1 has enforced all asp.net to run under "Medium Trust" - that said, if you try to update trust level from web.config it won't work as 1and1 has disabled overrides.

Any update your end?

Thanks
devvvy
  •  devvvy
  • 52.4% (Neutral)
  • YAF Forumling
2009-10-18T07:31:58Z
Can anyone tell us exactly what trust we need so we can at least tell our hosting provider what permission needs to be granted?

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved