jdmc43
  •  jdmc43
  • 51.8% (Neutral)
  • YAF Forumling Topic Starter
2009-07-22T06:51:46Z
Hello,

Our company has an existing yaf forum running on Server 2003 SBS which as far as i can tell is running version 1.9.0 (i did not install it). It is using SQL Server 2000.

We are upgrading the IT and i need to somehow make a fresh yaf install on another server (Server 2003 - 32bit, can't see anything when i try it on 64 bit) and copy over the existing forum.

I have managed to startup an empty forum using the 1.9.0 zip file i found on the old SBS server using SQL Server 2008.

I have tried using the export wizard to copy the database across. this is initially succesful and creates a new database. however when i then try and run the default.aspx file it runs into errors saying that the sys_vaccess table exists, if i delete it then it just creates another error instead... i can supply screenshots if required

lots of the instructions in the install.txt seem to relate to upgrading a database on a single machine and not transferring it. i tried taking a backup, but of course the new machine doesn't know that a backup was ever made of any database when i try and restore....

What is the best way to try and effect this transfer? I am making it up as i am going along, i have no experience of using ISS or SQL except that which i have gleaned in the last few days. so my problems are highly likely caused by general inexperience.

I appreciate any help that you can provide me with in this matter

dc
Sponsor
Mek
  •  Mek
  • 100% (Exalted)
  • YAF Developer
2009-07-22T08:29:58Z
Create a blank new database on the new server with the same database name as your YAF DB on the old server. Restore your backup to that database.

Don't try the export wizards. Sometimes they take the Views as tables.


UserPostedImage 

"It's a case of RTFM.. the only problem being we don't have a manual!"

When I post FP:Mek in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting. (Yes I stole this off Ederon 🙂 )
jdmc43
  •  jdmc43
  • 51.8% (Neutral)
  • YAF Forumling Topic Starter
2009-07-22T09:46:59Z
Hi

thanks for your prompt reply, i have a couple of questions so that i might do this.

when i backup the database in SQL SERVER 2000 (SP3a) Can i use TOOLS->BACKUP DATABASE... menu?

if i do this then i backup to a file, i guess i can make this database.bak

i then copy this .bak file to the new server, do i need to put it in a special place, i tried C:\"SQL install dir"\BACKUP which existed already...

then when i try and restore the blank database as you suggest if i use TOOLS->RESTORE DATABASE.. i cannot find the database.bak file to select and restore from...

thanks in advance

dc
jdmc43
  •  jdmc43
  • 51.8% (Neutral)
  • YAF Forumling Topic Starter
2009-07-22T11:16:22Z
Don't worry, i got it working using the restore, i just had to fumble about a bit in the restore from device section, once i got that right it worked a charm!!!

thanks very much for your help

dickon
Mek
  •  Mek
  • 100% (Exalted)
  • YAF Developer
2009-07-22T14:46:48Z
Glad you got it sorted mate.

UserPostedImage 

"It's a case of RTFM.. the only problem being we don't have a manual!"

When I post FP:Mek in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting. (Yes I stole this off Ederon 🙂 )

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved