midwestSS
2009-01-27T13:55:25Z
ok
just the other day i noticed my quick reply links no longer work, and the page loads showing
Javascript error: yafEditor is undefined

help?
Sponsor
logan
  •  logan
  • 100% (Exalted)
  • YAF Leader
2009-01-27T14:02:00Z
can you hide the quick reply box in the admin panel

is this 193RC2
test
midwestSS
2009-01-27T14:05:49Z
yes that is the version.. i clicked to hide that, but it didnt hide it.
id like to know why it broke cuz my users like this feature.
logan
  •  logan
  • 100% (Exalted)
  • YAF Leader
2009-01-27T14:19:23Z
Pages/posts.ascx

approx line 133 find

<asp:PlaceHolder ID="QuickReplyPlaceHolder" runat="server">
		<tr>
			<td colspan="3" class="post" style="padding: 0px;">
				<YAF:DataPanel runat="server" ID="DataPanel1" AllowTitleExpandCollapse="true" TitleStyle-CssClass="header2"
					TitleStyle-Font-Bold="true" Collapsed="true" visible="<%# PageContext.BoardSettings.ShowQuickAnswer %>">
					<div class="post quickReplyLine" id="QuickReplyLine" runat="server">





see if you are missing this
visible="<%# PageContext.BoardSettings.ShowQuickAnswer %>"

test
midwestSS
2009-01-27T14:24:20Z
here is my data..

	<asp:PlaceHolder ID="QuickReplyPlaceHolder" runat="server">
		<tr>
			<td colspan="3" class="post" style="padding: 0px;">
				<YAF:DataPanel runat="server" ID="DataPanel1" AllowTitleExpandCollapse="true" TitleStyle-CssClass="header2"
					TitleStyle-Font-Bold="true" Collapsed="true">
					<div class="post quickReplyLine" id="QuickReplyLine" runat="server">
					</div>
					<div id="CaptchaDiv" align="center" visible="false" runat="server">
						<br />
						<table class="content">
							<tr>
								<td class="header2">
									<YAF:LocalizedLabel ID="LocalizedLabel13" runat="server" LocalizedTag="Captcha_Image" />
								</td>
							</tr>
							<tr>
								<td class="post" align="center">
									<asp:Image ID="imgCaptcha" runat="server" AlternateText="Captcha" /></td>
							</tr>
							<tr>
								<td class="post">
									<YAF:LocalizedLabel ID="LocalizedLabel14" runat="server" LocalizedTag="Captcha_Enter" />
									<asp:TextBox ID="tbCaptcha" runat="server" /></td>
							</tr>
						</table>
						<br />
					</div>
					<div align="center" style="margin: 7px;">
						<asp:Button ID="QuickReply" CssClass="pbutton" runat="server" />
					</div>
				</YAF:DataPanel>
			</td>
		</tr>
	</asp:PlaceHolder>
logan
  •  logan
  • 100% (Exalted)
  • YAF Leader
2009-01-27T14:31:20Z
add this after Collapsed="true"

visible="<%# PageContext.BoardSettings.ShowQuickAnswer %>"

i just looked at the most recent ssvn i have and its not in there either.

forgot all about this until now.
test
midwestSS
2009-01-27T14:35:35Z
i added that.. but still no luck on the quick reply
www.silveradoss.net  is the site if you wanna pull it up and maybe see the error.
logan
  •  logan
  • 100% (Exalted)
  • YAF Leader
2009-01-27T14:36:43Z
I dont remember any errors tho, but this will allow hiding the box when unchecking in admin
test
midwestSS
2009-01-27T14:40:28Z
ok i think i gotta wait for it to cache out... its still showing.
Mek
  •  Mek
  • 100% (Exalted)
  • YAF Developer
2009-02-23T09:20:59Z
If you've still got the issue with the javascript displaying YAFEditor is undefined; most likely your baseurl is not set properly to the location of where your YAF is installed.
I've just encountered the same problem where my YAF folder was actually ~/Modules/Forums . setting baseurl in the app.config to this sorted out my woes.

UserPostedImage 

"It's a case of RTFM.. the only problem being we don't have a manual!"

When I post FP:Mek in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting. (Yes I stole this off Ederon 🙂 )

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved