logan
  •  logan
  • 100% (Exalted)
  • YAF Leader Topic Starter
2008-10-13T13:40:42Z
After getting my forum up and running, I have found that the Emails
are not being sent by users.

Admin Mail works
Admin email to user works
Admin email topic works
Admin email from user profile works

No Email from user works
cannot email topic or email from profile

watch topic sends an Email, the first new post but not after
any more new posts.

I also tried sending myself an email from this forum and it also failed to send.

If you have all the email system working Any help would be great.

Seems like emails are on 2 different systems. Admin and User??

Thanks for any help
test
Sponsor
xb90
  •  xb90
  • 55.4% (Neutral)
  • YAF Forumling
2008-10-31T14:35:36Z
I'm seeing the same problem with users unable to send email.

YAF: 1.9.3 RC2
Hosting by Godaddy


I believe (in my case) this is related to some previous postings wrt problems with GoDaddy email.

I haven't got a user email to work yet, but I suspect that the FROM address specified in the site-generated email is the user's email address (that would make sense).

If the FROM email entry happens to be on AOL, GMAIL, or YAHOO, then GoDaddy will block it.

The related entry in Yaf_Eventlog table is:

System.Net.Mail.SmtpException: Mailbox name not allowed. The server response was: sorry, your mail was administratively denied. (#5.7.1) at System.Net.Mail.MailCommand.CheckResponse(SmtpStatusCode statusCode, String response) at System.Net.Mail.MailCommand.Send(SmtpConnection conn, Byte[] command, String from) at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, SmtpFailedRecipientException& exception) at System.Net.Mail.SmtpClient.Send(MailMessage message) at YAF.Classes.Utils.SendMail.Send(MailAddress fromAddress, MailAddress toAddress, String subject, String bodyText, String bodyHtml) at YAF.Classes.Utils.SendMail.Send(MailAddress fromAddress, MailAddress toAddress, String subject, String bodyText) at YAF.Pages.im_email.Send_Click(Object sender, EventArgs e) in d:\hosting\3172706\html\pages\im_email.ascx.cs:line 86

This error is consistent with what GoDaddy has communicated to earlier this week regarding blocking \emails where the above listed domains are specified in the FROM address.

As a possible solution, could YAF be configured to use an alternative FROM address when a user attempt to send an email to another user? Possibly a "DoNotReply@sitename.whatever" with a "mailto" link embedded in the message which contains the sending user's email address?
idunno
2008-11-08T05:14:56Z
Good luck fixing your user email issue !

I just tried to send you email through this forum, and it gave me an error.
vash
  •  vash
  • 100% (Exalted)
  • YAF Commander
2008-11-19T13:49:04Z
Im having the same problem with email sending.

1. Email for new registration stopped working
2. Email notification for new post stopped working
3. Admin Page email user is working

Im using YAF v1.9.3.Alpha

Before, everything is working fine. It suddenly stopped working on it's own. Any insight will be of great help.

P.S. I've also checked the YAF_mail table for malformed emails but all emails there are in the proper format.

Thanks

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved