tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2019-05-07T12:02:15Z
Have just upgraded to 2.2.5. The same problem with code blocks.

I was going to upload a screenshot demonstrating how it looks in the newest version, but unfortunately file uploading does not work on this forum anymore...
tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2019-05-07T14:52:21Z
Well, I experimented with the YAF CSS code. It seems, the following setting in themes\Yafmobile\theme.css makes Code blocks look more-or-less adequate to other Quote and Attachment blocks in the same thread:

.yafnet div.code div, .yafnet div.code {
    max-width: 65vw;
}

( the original setting was 85vw )

BTW, you can reproduce all layout problems I get on my Android smartphone using the device emulation  in Chrome DevTools on a big pc (hope, you know this tool). It allowed me to reproduce exactly the same layout I see on my Android smartphone on my pc with Windows 10.
tha_watcha
2019-05-07T15:37:02Z
Yes i use the tool. But when i view your forum everything is okay. even the buttons

UserPostedImage
UserPostedImage
tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2019-05-07T15:40:37Z
Now Code blocks look good as I changed their width to 65vw. You can use the DevTools and temporarily change this setting to the default value of 85vw to see the problem.
tha_watcha
2019-05-07T16:01:47Z
Originally Posted by: tecman 

Now Code blocks look good as I changed their width to 65vw. You can use the DevTools and temporarily change this setting to the default value of 85vw to see the problem.



Ah okay i change it.
UserPostedImage

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved