Mridul
  •  Mridul
  • 58.4% (Neutral)
  • YAF Camper Topic Starter
2016-06-08T11:35:49Z
i am getting the email error like below whenever i am trying to send digest or email verification.....


Exception Getting Digest: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 127.0.0.1:1297 at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress) at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception) --- End of inner exception stack trace --- at System.Net.HttpWebRequest.GetResponse() at YAF.Core.Services.YafDigest.GetDigestHtml(Int32 userId, Object boardSettings, Boolean showErrors) at YAF.Pages.Admin.digest.TestSend_Click(Object sender, EventArgs e)


and in event log:

Exception Thrown in SendMail Thread: System.InvalidOperationException: The SMTP host was not specified. at System.Net.Mail.SmtpClient.CheckHostAndPort() at System.Net.Mail.SmtpClient.Send(MailMessage message) at YAF.Core.Services.YafSendMail.SendAll(IEnumerable`1 messages, Action`2 handleException)
Sponsor
tha_watcha
2016-06-08T13:53:18Z
Did you set up the email account in the mail.config?
UserPostedImage
Mridul
  •  Mridul
  • 58.4% (Neutral)
  • YAF Camper Topic Starter
2016-06-08T14:14:10Z
Yes... Everything is working fine when I use the same mail settings from another demo website...

Please help
tha_watcha
2016-06-10T06:45:44Z
And did you setup the email in the board settings as email address for the forum?
UserPostedImage
Mridul
  •  Mridul
  • 58.4% (Neutral)
  • YAF Camper Topic Starter
2016-06-10T07:04:19Z
yes i did...its same as my credentials for sending email...nothing is working out..should i host my forum online and check whether its my local machine issue...what you suggest..??? And i forgot to tell you that even uploading option is not working for avatar..or for some attachment...

I am tensed...kindly guide me...
tha_watcha
2016-06-10T07:20:25Z
Sorry but with that issue i can not help you, this is an issue with your server not with yaf. Because it seems that your server blocks the outgoing connections it could be a firewall issue or an proxy.
UserPostedImage
Mridul
  •  Mridul
  • 58.4% (Neutral)
  • YAF Camper Topic Starter
2016-06-10T07:51:16Z
so should i host my yaf online...does that make any differnece...???
tha_watcha
2016-06-10T07:59:10Z
Originally Posted by: Mridul 

so should i host my yaf online...does that make any differnece...???



You only need to make sure that the server or pc you run yaf on Dont block any outgoing connections to the internet.
UserPostedImage

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved