Took me a few hours to figure this out and didn't find much help online. Eventually solved it. Here's what I did so maybe I can save others some time.

Fresh install of YAF 2.2.2
Win2012 server with IIS 8.5
SQL Server 2012 Express

Eventually solved it by using SQL Server Management Studio to create an empty yafnet database. Then went to the Security...Logins and make sure there was an account for IIS APPPOOL\DefaultAppPool. Under UserMappings for the DefaultAppPool account, made sure that for the yafnet database, the user had db_datareader and db_datawriter permissions checked. Also had to check db_owner which makes me a little nervous, but if it is unchecked, the YAF install process keeps running. If anyone has a suggestion that is a little bit more restrictive than db_owner, let me know.

After that, the install process for YAF executed just fine.
  •  bbobb
  • 100% (Exalted)
  • YAF Developer
db_owner is because YAF creates a lot of various ofbjects. You can change it later, if required. This is not a problem.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved