Rawbert
  •  Rawbert
  • 94.2% (Exalted)
  • YAF Commander Topic Starter
2014-03-03T05:17:05Z
Everything was working fine on the first board I created for my site fruitsteading.com .
Now I added a second board to use it with my new domain/site fruitandstarch.com  and it seems that YAF can't manage the user accounts right.
1. There's no profile pic for any of my fruitandstarch users. All new DNN user accounts.
2. The fruitandstarch admin RawbertFL shows up on the fruitsteading member list which is not desired.
100

Click to View Image


3. When you hover your mouse over a fruitandstarch user you get an error: 'Sorry, no data found or something went wrong.SyntaxError: Unexpected token E'
101

Click to View Image


4. Why the error links to fruitsteading, when the problem is with fruitandstarch?

Please check pics for details. I'm on the latest DNN and YAF versions.

Full error details from admin event viewer:

RawURL:/DesktopModules/YetAnotherForumDotNet/resource.ashx?url=www.fruitsteading.com%2fLinkClick.aspx%3ffileticket%3d_tCRhm2VSDE%253d&width=148&height=150

AbsoluteURL:/DesktopModules/YetAnotherForumDotNet/resource.ashx

AbsoluteURLReferrer:http://fruitsteading.com/Forum/g/members/Fruitsteading-Forums

UserAgent:Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.117 Safari/537.36

DefaultDataProvider:DotNetNuke.Data.SqlDataProvider, DotNetNuke

ExceptionGUID:56e39aef-1a43-43f6-a2cd-3898801936b1

InnerException:Unhandled Error:

FileName:

FileLineNumber:0

FileColumnNumber:0

Method:System.IO.Path.CheckInvalidPathChars

StackTrace:

Message:

System.Exception: Unhandled Error: ---> System.ArgumentException: Illegal characters in path.
at System.IO.Path.CheckInvalidPathChars(String path, Boolean checkAdditional)
at System.Security.Permissions.FileIOPermission.AddPathList(FileIOPermissionAccess access, AccessControlActions control, String[] pathListOrig, Boolean checkForDuplicates, Boolean needFullPath, Boolean copyPathList)
at System.IO.Path.GetFullPath(String path)
at System.Net.WebClient.GetUri(String path)
at System.Net.WebClient.OpenRead(String address)
at YAF.YafResourceHandler.GetResponseRemoteAvatar(HttpContext context)
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
--- End of inner exception stack trace ---
Sponsor
tha_watcha
2014-03-03T13:01:11Z
1 Did you tried using the "Import User" Option to sync all profiles?
2. Is only the admin visible in the wrong board or all users?

If only the admin, how did you create the new board and the new admin?

3 & 4 seems to be specific to that admin user who shows up at the wrong board
UserPostedImage
Rawbert
  •  Rawbert
  • 94.2% (Exalted)
  • YAF Commander Topic Starter
2014-03-03T13:43:25Z
Originally Posted by: tha_watcha 

1 Did you tried using the "Import User" Option to sync all profiles?
2. Is only the admin visible in the wrong board or all users?

If only the admin, how did you create the new board and the new admin?

3 & 4 seems to be specific to that admin user who shows up at the wrong board



1. Yes, I tried importer, no change at all.
2. Yes, only the admin. I created the new admin from within DNN logged in as superuser in fruitandstarch (the new site). The new board I created from YAF host settings within fruitsteading (the old site). I now created another new board from within fruitandstarch (the new site) by going to 'Edit DNN-YAF settings' > Create new board; same results.. :(

3 & 4 applies to ALL users, not just the admin!

I since created a few more boards and added them to various sites and I have the same issues on all of them.. something is terribly wrong here watcha!!
tha_watcha
2014-03-05T11:45:03Z
1. confirmed working on a fix

2. I think i now the problem when you create a new dnn portal you asked to create a new admin, you do that. Login with the new admin and add the yaf module to a new page. Then the board from the other dnn site, then you go to 'Edit DNN-YAF settings' > Create new board.

And that is the problem once the board from the other site is loaded the admin is created in the wrong board. At the moment you can only avoid it when you login with the host user to the second site, which is in both portals the same user.

3. confirmed working on a fix
UserPostedImage
Rawbert
  •  Rawbert
  • 94.2% (Exalted)
  • YAF Commander Topic Starter
2014-03-06T23:08:12Z
Originally Posted by: tha_watcha 

1. confirmed working on a fix

2. I think i now the problem when you create a new dnn portal you asked to create a new admin, you do that. Login with the new admin and add the yaf module to a new page. Then the board from the other dnn site, then you go to 'Edit DNN-YAF settings' > Create new board.

And that is the problem once the board from the other site is loaded the admin is created in the wrong board. At the moment you can only avoid it when you login with the host user to the second site, which is in both portals the same user.

3. confirmed working on a fix



1. Awesome! :)
2. You can't access 'Edit DNN-YAF settings' logged in as admin, only as host. So I was logged in as a host all the time. You should try to put in an option to not load the old board by default when adding the yaf module to a new site.
3. Awesome! :)
4. Also yaf should sync all dnn users as right now it doesn't which is fine for a new site, but what if you want to add it to a site with 100's of existing users?
Rawbert
  •  Rawbert
  • 94.2% (Exalted)
  • YAF Commander Topic Starter
2014-03-24T05:02:05Z
Any news on this watcha?
tha_watcha
2014-03-24T12:00:21Z
Originally Posted by: Rawbert 

Any news on this watcha?



No sorry, didnt have much free time lately. i'm working 7 days a week in my regular job, last week over 100 hours. I hope this week is a little bit better.
UserPostedImage
tha_watcha
2014-03-27T13:33:15Z
Ok all issues should be fixed now, new Release or BETA version of 2.1.2 on the weekend.
UserPostedImage
Rawbert
  •  Rawbert
  • 94.2% (Exalted)
  • YAF Commander Topic Starter
2014-03-28T02:03:42Z
Awesome, thank you watcha!!!
Rawbert
  •  Rawbert
  • 94.2% (Exalted)
  • YAF Commander Topic Starter
2014-05-06T03:46:21Z
Originally Posted by: tha_watcha 

Ok all issues should be fixed now, new Release or BETA version of 2.1.2 on the weekend.



Hey watcha unfortunately the issues persist even with the latest Beta2 release.. 😞

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved