jdixon
  •  jdixon
  • 51.2% (Neutral)
  • YAF Forumling Topic Starter
2014-02-09T23:35:01Z
I'm pretty sure I have the mail settings correct but I keep getting this message under events for YAF

Exception Thrown in SendMail Thread: System.InvalidOperationException: The SMTP host was not specified. at System.Net.Mail.SmtpClient.CheckHostAndPort() at System.Net.Mail.SmtpClient.Send(MailMessage message) at YAF.Core.Services.YafSendMail.SendAll(IEnumerable`1 messages, Action`2 handleException)

Here is my mail.config (all of it):

<!--
	SMTP setup for sending of e-mails from your forum.
	If the SMTP is SSL, you must edit the appSettings and set
	"YAF.UseSMTPSSL" to "true".
-->
<smtp deliveryMethod="Network" from="forums@domain.com">
	<!-- Uncomment to specify SMTP settings -->
	<network host="mail.domain.com" port="2525" password="MYPASSWORD" userName="forums@domain.com" />
</smtp>

<!-- Use this setting for development: pickup directory must be exact path -->
<!--smtp deliveryMethod="SpecifiedPickupDirectory">
	<specifiedPickupDirectory pickupDirectoryLocation="C:\Inetpub\wwwroot\email" />
</smtp-->


And the web.config is still right:

<system.net>
<mailSettings>
<smtp configSource="mail.config" />
</mailSettings>
</system.net>
Sponsor
jdixon
  •  jdixon
  • 51.2% (Neutral)
  • YAF Forumling Topic Starter
2014-02-10T02:41:18Z
I got it working by doing an IISRESET

Now i get this new error:
System.Net.Mail.SmtpException: Mailbox unavailable. The server response was: 5.7.1 Client does not have permissions to send as this sender


I'm not understanding how YAF is sending the email. My "From" email is the same as the mailbox I'm authenticating with. How does it not have permissions to send as the sender using its own mailbox?
tha_watcha
2014-02-10T11:54:33Z
Originally Posted by: jdixon 

I got it working by doing an IISRESET

Now i get this new error:
System.Net.Mail.SmtpException: Mailbox unavailable. The server response was: 5.7.1 Client does not have permissions to send as this sender


I'm not understanding how YAF is sending the email. My "From" email is the same as the mailbox I'm authenticating with. How does it not have permissions to send as the sender using its own mailbox?



Is the Forum Email defined in the Board Settings the same as used in the mail.config?


UserPostedImage
Gofer01
2014-02-10T18:59:37Z
Originally Posted by: tha_watcha 

Originally Posted by: jdixon 

I got it working by doing an IISRESET

Now i get this new error:
System.Net.Mail.SmtpException: Mailbox unavailable. The server response was: 5.7.1 Client does not have permissions to send as this sender


I'm not understanding how YAF is sending the email. My "From" email is the same as the mailbox I'm authenticating with. How does it not have permissions to send as the sender using its own mailbox?



Is the Forum Email defined in the Board Settings the same as used in the mail.config?



Watacha Tell me what's wrong with this code



<smtp deliveryMethod="Network" from="forums@domain.com">
	<!-- Uncomment to specify SMTP settings -->
	<network host="mail.domain.com" port="2525" password="MYPASSWORD" userName="forums@domain.com" />
</smtp>


If you can't figure it out. I will tell you. This forum web application been using this code for years.
Michael
My Website 
tha_watcha
2014-02-11T00:31:44Z
Yes please let as know what the Problem is. I use the Same settings in all of My Forums without any Problems (of Course with the correct credentials)
UserPostedImage

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved