Glitchmaster_PE
2013-09-05T01:13:29Z
Hi, I would begin by saying that I really like your all's forums! They are very clean and easy to use. Here is my question: I have a site made using WordPress ( http://pecrafters.com  ) and I have my forums set up using YAF ( http://pecrafters.com/forums/  ). I want my login to redirect to: http://pecrafters.com/?page_id=28  I have this entered in the redirect url field: http://pecrafters.com/?p...8?returnurl=%2fforums%2f  , it takes you to the login page, but does not then redirect you back to the forums. Any help is apprectiated!

Glitchmaster_PE
Sponsor
Glitchmaster_PE
2013-09-08T19:46:56Z
johnk
  •  johnk
  • 74.2% (Friendly)
  • YAF All-the-Time
2013-09-09T01:02:56Z
Try changing

Quote:

http://pecrafters.com/?page_id=28?returnurl=%2fforums%2f



to

Quote:

http://pecrafters.com/?page_id=28&returnurl=%2fforums%2f

Glitchmaster_PE
2013-09-09T20:28:36Z
It didnt work 😞
johnk
  •  johnk
  • 74.2% (Friendly)
  • YAF All-the-Time
2013-09-09T22:26:58Z
There should only be one question mark in the url.

Quote:

http://pecrafters.com/?page_id=28&returnurl=/forums/


Glitchmaster_PE
2013-09-11T22:50:02Z
It didnt work 😞
tha_watcha
2013-09-12T11:22:28Z
Originally Posted by: Glitchmaster_PE 

Hi, I would begin by saying that I really like your all's forums! They are very clean and easy to use. Here is my question: I have a site made using WordPress ( http://pecrafters.com  ) and I have my forums set up using YAF ( http://pecrafters.com/forums/  ). I want my login to redirect to: http://pecrafters.com/?page_id=28  I have this entered in the redirect url field: http://pecrafters.com/?p...8?returnurl=%2fforums%2f  , it takes you to the login page, but does not then redirect you back to the forums. Any help is apprectiated!

Glitchmaster_PE



Which login page did you mean, the one in wordpress or the one in yaf, where the redirect url doesnt work?

With wordpress nobody here can help you here because we only do .NET and not PHP here.

But if you mean the yaf login page, there is a bug in the urlrewriter.config. Which prevents the redirecturl parameter to not work. This issue can be fixed if you update your urlrewriter.config. replace the line...

<rewrite url="^~/(.+?)?yaf_login?\.aspx(\?(.+))?$" to="~/$1Default.aspx?g=login&amp;$5" processing="stop" />

with that line...
<rewrite url="^~/(.+?)?yaf_login?\.aspx\?(.+)?$" to="~/$1Default.aspx?g=login&amp;$2" processing="stop" />
UserPostedImage
Glitchmaster_PE
2013-09-12T11:37:08Z
Thank you, I will try that
Glitchmaster_PE
2013-09-12T20:29:22Z
No, I believe it is a problem with the WordPress redirect, thank you all for trying to help 🙂

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved