jpweber
  •  jpweber
  • 94.4% (Exalted)
  • YAF Commander Topic Starter
2012-04-12T14:33:52Z
I recently upgraded from 1.95 to YAF-v1.9.6.1-RTW-SRC, and I went through the process www.ussvision.com/knowle...ase/install/default.aspx  .... I actually edited my db.config and app.config manually, but everything eventually tested out successfully. But when I try to open my YAF (my knowledgebase), I get the following:


Quote:

http://www.ussvision.com/knowledgebase/error404?aspxerrorpath=/knowledgebase/yaf_login.aspx

Server Error in Application "USSVISION.COM/KNOWLEDGEBASE"
Internet Information Services 7.5
Error Summary
HTTP Error 404.0 - Not Found
The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.
Detailed Error Information
Module IIS Web Core
Notification MapRequestHandler
Handler StaticFile
Error Code 0x80070002
Requested URL http://www.ussvision.com:80/knowledgebase/error404?aspxerrorpath=/knowledgebase/Default.aspx?g=login&=
Physical Path E:\web\ussvisionco\htdocs\knowledgebase\error404
Logon Method Anonymous
Logon User Anonymous
Failed Request Tracing Log Directory E:\web\ussvisionco\htdocs



Does anyone know a possible remedy for this? Thanks!
jpweber attached the following image(s):

Jason Weber
USS Vision YAF 
"Money is better than poverty, if only for financial reasons"
Sponsor
squirrel
2012-04-12T14:47:55Z
Originally Posted by: jpweber 

I recently upgraded from 1.95 to YAF-v1.9.6.1-RTW-SRC, and I went through the process www.ussvision.com/knowle...ase/install/default.aspx  .... I actually edited my db.config and app.config manually, but everything eventually tested out successfully. But when I try to open my YAF (my knowledgebase), I get the following:


Quote:

http://www.ussvision.com/knowledgebase/error404?aspxerrorpath=/knowledgebase/yaf_login.aspx

Server Error in Application "USSVISION.COM/KNOWLEDGEBASE"
Internet Information Services 7.5
Error Summary
HTTP Error 404.0 - Not Found
The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.
Detailed Error Information
Module IIS Web Core
Notification MapRequestHandler
Handler StaticFile
Error Code 0x80070002
Requested URL http://www.ussvision.com:80/knowledgebase/error404?aspxerrorpath=/knowledgebase/Default.aspx?g=login&=
Physical Path E:\web\ussvisionco\htdocs\knowledgebase\error404
Logon Method Anonymous
Logon User Anonymous
Failed Request Tracing Log Directory E:\web\ussvisionco\htdocs



Does anyone know a possible remedy for this? Thanks!



Try compaying your app.config files -- there might be a setting regarding your URLs that needs to be updated. That or you have some issue regarding file locations with the IIS Application. Depending on how YAF is installed as an application, the bin files and settings in the app.config might need to be altered.
If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
tha_watcha
2012-04-12T14:51:04Z
First you should run the upgrade wizzard

http://www.ussvision.com/knowledgebase/install/ 

It looks like there is a problem with the url rewriter does the UrlRewriter.config exists in your root folder?
UserPostedImage
jpweber
  •  jpweber
  • 94.4% (Exalted)
  • YAF Commander Topic Starter
2012-04-12T15:22:25Z
Hey tha_watccha. I did run the upgrade wizard, and everything tested out successfully, although I had to manually edit the db.config and app.config myself. Everything else works .... like I can use the admin, and I get get in there via www.ussvision.com/advanced.aspx  ....

Yes, I actually even tried using my old 1.95 urlrewriter.config, but then switched back to the 1.96.

So the entire YAF /knowledgebase/ folder is set as an application in IIS, and the urlrewriter.config is located in the /knowledgebase/ folder.

The /bin/ folder is also located in the /knowledgebase/ directory. So it's www.ussvision.com/knowledgebase/bin/  and all the .dll files are located in there. I don't know if I should have put the /bin/ in the root, so it would be www.ussvision.com/bin/  all the .dll files?

Not sure!
jpweber attached the following image(s):

Jason Weber
USS Vision YAF 
"Money is better than poverty, if only for financial reasons"
jpweber
  •  jpweber
  • 94.4% (Exalted)
  • YAF Commander Topic Starter
2012-04-12T19:13:10Z
Problem solved. I have /bin/ directories with the .dll files both in the website root AND the /knowledgebase/ directory.

Additionally, I made some changes to the app,.config.

I already had:

-->

<add key="YAF.AppRoot" value="/knowledgebase" />

<!--

But I took the trailing slash off of /knowledgebase/


Additionally, this comment was greyed out, but I changed it -- which I did NOT do in 1.95:

Quote:

** Optional File Root Key ** Defaults to: AppRoot (below) **

File Root is server-side and used by YAF to find and load files.

If YAF forum files are not located in the Application Root (~/)
of your web site you need to specify the additional url
in this root key. Example: Application Root is "/forum"
You want your forum at "www.mysite.com/forum". You need to specify
"/forum" in your root key below.

PLEASE NOTE:

YAF .dll files (from the \bin directory in the zip) AND ALL files
in the \App_Code directory MUST be located in the Application Root.


-->

<add key="YAF.FileRoot" value="/knowledgebase"/>
<!--



I'm not sure if these changes were proper, but just through heuretic trial and error, this is what worked for me, and now my version of 1.96 seems to be functioning properly.

Hope this helps anybody else, and thanks for your help, Squirrel, and Tha_Watcha!
Jason Weber
USS Vision YAF 
"Money is better than poverty, if only for financial reasons"

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved