DaleDixon
  •  DaleDixon
  • 54.8% (Neutral)
  • YAF Forumling Topic Starter
2012-01-09T16:51:55Z
After installing v1.9.5.5 (new install) using a copy of an existing database (v1.9.1.8) I am unable to login using any account.

The Install successfully completed, and it appears that the database was successfully upgraded. I can see the forum, and the all the structure is there, just no login. I am able to create new users, and request new passwords.

Existing configuration:
Win 2003 R2 SP2, MSSQL 2005, IIS 6

New Configuration
Win 2003 R2 SP1, MSSQL 2008, IIS 7

Using the defaults in both existing and New instances.


Any Ideas?

Thanks, Dale
Sponsor
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer
2012-01-09T18:54:37Z
Did you use the upgrade web.config... before the upgrade?
DaleDixon
  •  DaleDixon
  • 54.8% (Neutral)
  • YAF Forumling Topic Starter
2012-01-09T18:59:10Z
Is that needed to upgrade the database?
I assumed that was for an in place upgrade of the application.
This was a clean install of 1.9.5.5
tha_watcha
2012-01-09T19:39:21Z
Originally Posted by: DaleDixon 

Is that needed to upgrade the database?
I assumed that was for an in place upgrade of the application.
This was a clean install of 1.9.5.5



Of course when you using an existing database you need to upgrade the db. In your case when you upgrade from version 1.9.1.x you need the upgrade config, because of the changes in the membership related stuff. Thats why you can not login.
UserPostedImage
DaleDixon
  •  DaleDixon
  • 54.8% (Neutral)
  • YAF Forumling Topic Starter
2012-01-09T21:16:32Z
I reinstalled following the directions for upgrading, and merged the upgrade web.config, into the web config from the existing 1.9.1.8 site.
I am still unable to log in. the Forum appears to be working, and I can browse the existing content in public areas.

Do I need to change the web.config after the upgrade?

Any more Ideas?
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer
2012-01-10T19:42:25Z
Can you post your membership/role/provider settings from your web.config here?
RichP714
2012-01-11T01:43:18Z
IIRC, this happened to me as well; make sure your web. config is using MD5 instead of SHA1

<membership defaultProvider="YafMembershipProvider" hashAlgorithmType="MD5">
Enjoy!

Running YAF 1.9.5.5 final at: http://thecarversite.com 
DaleDixon
  •  DaleDixon
  • 54.8% (Neutral)
  • YAF Forumling Topic Starter
2012-01-11T18:01:49Z
Here is the content of the web.config file:


<?xml version="1.0" encoding="utf-8"?>
<configuration>
<configSections>
<section name="rewriter" type="Intelligencia.UrlRewriter.Configuration.RewriterConfigurationSectionHandler, Intelligencia.UrlRewriter" requirePermission="false"/>
</configSections>
<connectionStrings configSource="db.config"/>
<appSettings configSource="app.config"/>
<rewriter configSource="URLRewriter.config"/>
<system.net>
<mailSettings>
<smtp configSource="mail.config"/>
</mailSettings>
</system.net>
<system.web>
<trace enabled="false"/>
<xhtmlConformance mode="Transitional"/>
<customErrors defaultRedirect="Error.aspx" mode="Off"/>
<!-- GLOBALIZATION
This section sets the globalization settings of the application.
Utf-8 is not supported on Netscape 4.x
If you need netscape compatiblity leave iso-8859-1.
UTF-8 is recommended for complex languages
-->
<globalization culture="en-US" uiCulture="en" requestEncoding="UTF-8" responseEncoding="UTF-8" fileEncoding="UTF-8" />
<!--<globalization culture="en-US" uiCulture="en" fileEncoding="iso-8859-1" requestEncoding="iso-8859-1" responseEncoding="iso-8859-1"/>-->
<authentication mode="Forms">
<forms name=".YAFNET_Authentication" protection="All" timeout="43200" cookieless="UseCookies"/>
</authentication>
<!-- Set debug to "true" to test out the system in development -->
<compilation defaultLanguage="c#" debug="false">
<assemblies>
<add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Data.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
<add assembly="System.ServiceModel.Web, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
</assemblies>
</compilation>
<httpHandlers>
<remove verb="*" path="*.asmx"/>
<add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false"/>
<add verb="GET" path="Resource.ashx" type="YAF.YafResourceHandler, YAF" />
</httpHandlers>
<httpModules>
<add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add name="YafTaskModule" type="YAF.Core.YafTaskModule, YAF.Core"/>
<add name="UrlRewriter" type="Intelligencia.UrlRewriter.RewriterHttpModule,Intelligencia.UrlRewriter"/>
</httpModules>
<pages validateRequest="false" smartNavigation="false">
<controls>
<add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<!-- Default: use non-dynamic (compiled classes) in YAF -->
<add tagPrefix="YAF" namespace="YAF.Controls" assembly="YAF.Controls"/>
<add tagPrefix="YAF" namespace="YAF.Controls.Statistics" assembly="YAF.Controls"/>
<add tagPrefix="YAF" namespace="YAF.Classes"/>
<add tagPrefix="YAF" namespace="YAF"/>
</controls>
<namespaces>
</namespaces>
</pages>
<roleManager enabled="true" defaultProvider="YafRoleProvider">
<providers>
<clear/>
<add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafRoleProvider" type="YAF.Providers.Roles.YafRoleProvider"/>
</providers>
</roleManager>
<membership defaultProvider="YafMembershipProvider" hashAlgorithmType="SHA1">
<providers>
<clear/>
<add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafMembershipProvider" requiresUniqueEmail="true" useSalt="true" type="YAF.Providers.Membership.YafMembershipProvider"/>
</providers>
</membership>
<profile enabled="true" defaultProvider="YafProfileProvider" inherits="YAF.Utils.YafUserProfile">
<providers>
<clear/>
<add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafProfileProvider" type="YAF.Providers.Profile.YafProfileProvider"/>
</providers>
</profile>
</system.web>
<system.webServer>
<validation validateIntegratedModeConfiguration="false"/>
<modules>
<remove name="ScriptModule"/>
<remove name="YafTaskModule"/>
<remove name="UrlRewriter"/>
<add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add name="YafTaskModule" type="YAF.Core.YafTaskModule, YAF.Core" preCondition="managedHandler"/>
<add name="UrlRewriter" type="Intelligencia.UrlRewriter.RewriterHttpModule,Intelligencia.UrlRewriter" preCondition="managedHandler"/>
</modules>
<handlers>
<remove name="WebServiceHandlerFactory-Integrated"/>
<remove name="ScriptHandlerFactory"/>
<remove name="ScriptHandlerFactoryAppServices"/>
<remove name="ScriptResource"/>
<add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add name="YafHandler" preCondition="integratedMode" verb="GET" path="Resource.ashx" type="YAF.YafResourceHandler, YAF" />
</handlers>
</system.webServer>
<system.codedom>
<compilers>
<compiler language="c#;cs;csharp" extension=".cs" warningLevel="4" type="Microsoft.CSharp.CSharpCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
<providerOption name="CompilerVersion" value="v3.5"/>
<providerOption name="WarnAsError" value="false"/>
</compiler>
<compiler language="vb;vbs;visualbasic;vbscript" extension=".vb" warningLevel="4" type="Microsoft.VisualBasic.VBCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
<providerOption name="CompilerVersion" value="v3.5"/>
<providerOption name="OptionInfer" value="true"/>
<providerOption name="WarnAsError" value="false"/>
</compiler>
</compilers>
</system.codedom>
</configuration>

Thanks,
SteveInTN
2012-01-11T18:08:24Z
Did you see the post from RichP714 above?
DaleDixon
  •  DaleDixon
  • 54.8% (Neutral)
  • YAF Forumling Topic Starter
2012-01-11T18:23:52Z
Originally Posted by: SteveInTN 

Did you see the post from RichP714 above?



Yes testing right now

Thanks
DaleDixon
  •  DaleDixon
  • 54.8% (Neutral)
  • YAF Forumling Topic Starter
2012-01-11T18:38:23Z
Originally Posted by: RichP714 

IIRC, this happened to me as well; make sure your web. config is using MD5 instead of SHA1

<membership defaultProvider="YafMembershipProvider" hashAlgorithmType="MD5">



This didn't fix it, thanks though.
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer
2012-01-11T19:26:31Z
That's not the upgrade membership settings... no wonder it won't work for you.

They are:


    <membership defaultProvider="YafMembershipProvider" hashAlgorithmType="MD5">
      <providers>
        <clear/>
        <add connectionStringName="yafnet" applicationName="YetAnotherForum" name="YafMembershipProvider" requiresUniqueEmail="false" type="YAF.Providers.Membership.YafMembershipProvider" hashHex="true" hashCase="upper" />
      </providers>
    </membership>

DaleDixon
  •  DaleDixon
  • 54.8% (Neutral)
  • YAF Forumling Topic Starter
2012-01-11T20:12:54Z
Thanks Jaben and all for your help!

One more question. Does the <applicationName="YetAnotherForum"> refer to the application name in IIS?
Does it need to be changed to what ever the application is named in IIS?

Thanks

Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer
2012-01-12T05:02:19Z
Originally Posted by: DaleDixon 

Thanks Jaben and all for your help!

One more question. Does the <applicationName="YetAnotherForum"> refer to the application name in IIS?
Does it need to be changed to what ever the application is named in IIS?

Thanks


Nope. They're unrelated. ASP.NET membership supports different users/roles PER application. So you can have a membership store for DotNetNuke and YAF.NET on the same database by giving them different application names.

Just another dimension, really.
DaleDixon
  •  DaleDixon
  • 54.8% (Neutral)
  • YAF Forumling Topic Starter
2012-01-12T05:23:13Z
Got it up and running!
Thanks guys for all the assistance.

- Dale

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved