trinzul
  •  trinzul
  • 50.6% (Neutral)
  • YAF Forumling Topic Starter
2011-11-09T14:01:34Z
I'm at a loss for what's going on when I try to write to the database to create a forum programmatically. Any help would be appreciated. Here is what I'm seeing.

I'm using Linq to SQL in an existing .NET project to create a new forum. I've tried writing a record to the yaf_forum table that looks identical to what is produced if I go through the process in the YAF admin section of the app. I then added records to the yaf_ForumAccess table to give my user the correct permissions to the forum.

When I log in and look at the forums listed for my user I see the forum I've created, but a couple of problems exist.The first thing I notice is that on the list of forums, that particular one has a "-" under the columns for Topics and Posts where a "0" is there for any forum created through the YAF admin console. The Last Post column is also blank where the YAF created forums show "No Posts".

The bigger problem is when I click on the forum to actually go to it I get a page that says "Object Moved To Here". It's a link that simply points to the same object moved page. So I can never actually get to the forum.

The database record looks identical to one auto created by YAF. I've even tried calling the stored procedure yaf_forum_save from Linq and I get a similar result. The database records look as they should, but the same problems exist with the actual form.

Any thoughts on what I am missing here?
Sponsor
doxa
2011-12-18T20:17:30Z
There is a proc, I used it but, it does not work properly. need to edit and post again. now, I left to create programmatically.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved