Deception
  •  Deception
  • 52.4% (Neutral)
  • YAF Forumling Topic Starter
2011-10-05T18:39:08Z
Hello Everyone!

I hope everyone is well,

Im new to DNN and struggling with installing YAF (yet another Forum), I have gone onto YAF site and downloaded this:
http://dnnyafnet.codeplex.com/releases/view/62034 

I have then logged in as host and tried to install it via the Extension Manager, everything thing seemed fine and DNN said it installed, I then clicked return to portal to find this error :

Could not load file or assembly 'YAF.Classes.Config' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.

followed by a load of code with yellow boxes.

and when trying to go back on the main site it just stays on that error.

can any one help? or point me in the right directions.

Thanks in advance!

J
Sponsor
tha_watcha
2011-10-06T02:56:55Z
Originally Posted by: Deception 

Hello Everyone!

I hope everyone is well,

Im new to DNN and struggling with installing YAF (yet another Forum), I have gone onto YAF site and downloaded this:
http://dnnyafnet.codeplex.com/releases/view/62034 

I have then logged in as host and tried to install it via the Extension Manager, everything thing seemed fine and DNN said it installed, I then clicked return to portal to find this error :

Could not load file or assembly 'YAF.Classes.Config' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.

followed by a load of code with yellow boxes.

and when trying to go back on the main site it just stays on that error.

can any one help? or point me in the right directions.

Thanks in advance!

J



The yaf version you try to install needs .NET 3.5 to run, did you have installed that version on your server?

UserPostedImage
Deception
  •  Deception
  • 52.4% (Neutral)
  • YAF Forumling Topic Starter
2011-10-06T19:11:31Z
Hi, thanks for the reply.

I forgot to add im using DNN 6 and Webmatrix and its running of my computer (local host).

I have installed the new frameworks both 3.5 and 4 and reinstalled DNN but it comes up with the same error.

on a side note i tried to install YAFDNN_Complete_1.95.5 and DNN asks weather its a skin, container or neither, I click neither and then next but it just refreshes ( if i click skin or container it goes to the install page)

here is the error:

UserPostedImage 

Uploaded with ImageShack.us 

thanks in advance.
tha_watcha
2011-10-07T10:42:11Z
Quote:

I have installed the new frameworks both 3.5 and 4 and reinstalled DNN but it comes up with the same error.



Did you set the App Pool of your App (DNN) to 4 in IIS?
UserPostedImage
Deception
  •  Deception
  • 52.4% (Neutral)
  • YAF Forumling Topic Starter
2011-10-07T20:41:20Z
Okay well i found the problem..... Webmatrix had it set to 2.0!!

it seems to install fine now, just one more question how do I replace the YaF config password? the installion guide doesn't tell me where it is.

Once again thank you for your time.

J
tha_watcha
2011-10-08T06:26:09Z
Quote:

it seems to install fine now, just one more question how do I replace the YaF config password? the installion guide doesn't tell me where it is.



Yes it does

Quote:

STEP 4. Modify the root web.config of your DotNetnuke. This is the most important step.

Replace the YAF Config Password <add key="YAF.ConfigPassword" value="XXXX" /> with one you like.


UserPostedImage
Deception
  •  Deception
  • 52.4% (Neutral)
  • YAF Forumling Topic Starter
2011-10-08T19:07:56Z
sorry i was meant to say i didn't know where to find web.config, but all it's fine after some digging into DNN.

Anyway I have installed YAF on DNN6 🙂 So im happy.

Thank you for your help!
Gofer01
2011-10-12T10:04:39Z
the YAF password settings is in app.config file. Look at line 12


<appSettings>
  <!--
  ******************************************************************
	** ConfigPassword Key ** Defaults to: Empty (not installed) **
  
  Password to run configuration (/install/default.aspx) for the forum.
  If you cannot set write permissions on this file (app.config)
  you can manually enter a plain text password here that will
	be required when you attempt to run the configuration. Install/config
	password is required for security reasons.
   -->
	<add key="YAF.ConfigPassword" value="MyPassword" />
	
  <!--
  ******************************************************************


Michael
My Website 
Gofer01
2011-10-12T10:17:46Z
Did you get YAF 1.9.5 to work with DNN 6.0.1 on a web server. Not on locahost? I have simular issues with these two web applications.

http://forum.mydomainname.com  but that cost money. I rather run the forum in a sub directory off of the main DNN 6.0.1 root directory.
Michael
My Website 

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved