kfrehafer
  •  kfrehafer
  • 52.4% (Neutral)
  • YAF Forumling Topic Starter
2011-06-24T19:47:50Z
I am using YAF 1.9.5.5 with DNN 5.6.2 as an installed extension module. Everything is working, except I am unable to upload attachments in forum posts or in user profile albums. User roles/rankings and attachment settings are all set up to allow uploads. When attempting, I get a "Could not find a part of the path" error message, with a weird looking path such as
'E:\inetpub\vhosts\mydomain.org\httpdocs\DesktopModules\YetAnotherForumDotNet\Uploads\5.imagename.jpg.yafupload'

I found this YAF Forum Thread  and thought I found the solution. However, I could not find a "<uploaddir>/upload/</uploaddir>" line in the web.config file that I could change per the post.

So, I am unable to upload any files or pictures. I hope someone can point me to the solution, as YAF appears to be a much better forum than the DNN core forum module.

Thanks.

Ken
Sponsor
squirrel
2011-06-24T21:34:32Z
Originally Posted by: kfrehafer 

I am using YAF 1.9.5.5 with DNN 5.6.2 as an installed extension module. Everything is working, except I am unable to upload attachments in forum posts or in user profile albums. User roles/rankings and attachment settings are all set up to allow uploads. When attempting, I get a "Could not find a part of the path" error message, with a weird looking path such as
'E:\inetpub\vhosts\mydomain.org\httpdocs\DesktopModules\YetAnotherForumDotNet\Uploads\5.imagename.jpg.yafupload'

I found this YAF Forum Thread  and thought I found the solution. However, I could not find a "<uploaddir>/upload/</uploaddir>" line in the web.config file that I could change per the post.

So, I am unable to upload any files or pictures. I hope someone can point me to the solution, as YAF appears to be a much better forum than the DNN core forum module.

Thanks.

Ken



Make sure there is an uploads folder inside your YetAnotherForumDotNet folder as it shows above and that it is writable by the worker process that is serving your forums. That should solve the issue.

To change the upload path, modify the app.config file in your YAF folder - but uploads will have to go somewhere inside the YAF folder you are running from (or atleast within your DNN root folder tree) - that is the only limitation that I know of

If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
kfrehafer
  •  kfrehafer
  • 52.4% (Neutral)
  • YAF Forumling Topic Starter
2011-06-24T22:49:20Z
That was a simple and elegant reply 🙂 !

Thanks ever so much. All is well.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved