beast_b9
  •  beast_b9
  • 55.4% (Neutral)
  • YAF Forumling Topic Starter
2011-04-28T09:48:06Z
When i click post i got this

Server Error in '/' Application.
Sequence contains no elements
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.InvalidOperationException: Sequence contains no elements

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[InvalidOperationException: Sequence contains no elements]
System.Linq.Enumerable.First(IEnumerable`1 source) +731024
YAF.Pages.posts.BindData() +1526
YAF.Pages.posts.Page_Load(Object sender, EventArgs e) +3811
System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +14
System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +35
System.EventHandler.Invoke(Object sender, EventArgs e) +0
System.Web.UI.Control.OnLoad(EventArgs e) +99
System.Web.UI.Control.LoadRecursive() +50
System.Web.UI.Control.LoadRecursive() +141
System.Web.UI.Control.LoadRecursive() +141
System.Web.UI.Control.LoadRecursive() +141
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +627


when i klick return button everythin is ok, but on every post i got this.
Sponsor
tha_watcha
2011-04-28T11:10:23Z
beast_b9
  •  beast_b9
  • 55.4% (Neutral)
  • YAF Forumling Topic Starter
2011-04-28T11:41:13Z
How can i fix this? i read this two links but i download version without back code, whre do i turn daylight savings of .. for this to work? thank you
beast_b9
  •  beast_b9
  • 55.4% (Neutral)
  • YAF Forumling Topic Starter
2011-05-02T09:40:54Z
I konw this is maybe not a good solution, but i ad some javascript in error.aspx to overried this error,.
<script language="javascript" type="text/javascript"> window.history.go(-3);</script>
it goes back three pages, that in my case goes to the start of the specifiec forum inn tree. Because if i set it two steps the new post doesn't shows (i have to manully refresh it) . If you can tell me what is the page that handles new topic? is it topic.aspx? i mean where is the hadler of button when i click post? Can this be done on out of the box application, or i have to use solution version (with c# code?
For now this will do the trick if i don't figure somethin out,
Users browsing this topic

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved