cschear
  •  cschear
  • 61.4% (Friendly)
  • YAF Camper Topic Starter
2010-11-29T20:03:39Z
I have noticed that the boards include both jQuery 1.4.4 & 1.3.2. I think the 1.3.2 version is coming from DNA controls. Has anyone else noticed this? Anyone know what these DNA controls are used for?
Sponsor
bbobb
  •  bbobb
  • 100% (Exalted)
  • YAF Developer
2010-11-29T20:33:39Z
Anyone knows :wink: It really comes with DNA. And you can't wipe them out as they used in many places.
tha_watcha currently deals with it. We prey for him. Hopufully they will be wiped out in the 1.9.5.

cschear
  •  cschear
  • 61.4% (Friendly)
  • YAF Camper Topic Starter
2010-11-29T20:39:27Z
I see - now that I'm perusing the source I can see how they are used. Thanks for the info.

Mek
  •  Mek
  • 100% (Exalted)
  • YAF Developer
2010-11-30T09:17:11Z
DNA does a check before it adds the Jquery:

if (HttpContext.Current.Items["AddJQueryRegistedHandler"] == null)


so if you set something like HttpContext.Current.Items["AddJQueryRegistedHandler"] = true; on your default page OnInit, it should not add the Jquery.

It will still add the JqueryUI and the individual Jquery elements though automatically. The onyl way to stop it doing that is to change every control in DNA.UI.Jquery project and recompile:


[JQuery(Name = "accordion", Assembly = "jQueryNet", DisposeMethod = "destroy", 
    ScriptResources = new[] { "ui.core.js", "effects.core.js", "ui.accordion.js", "plugins.easing.1.3.js" }, 
    StartEvent = ClientRegisterEvents.ApplicationLoad)]


If you remove the ScriptResources line, DNA won't register anything for this control. (Does mean you have to ensure that the require files are done manually though).

Not sure what further Jquery problems you might run into, was just sharing what routes I've gone with my MojoPortal integration. So the info is completely provided unsupported 😛
UserPostedImage 

"It's a case of RTFM.. the only problem being we don't have a manual!"

When I post FP:Mek in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting. (Yes I stole this off Ederon 🙂 )
cschear
  •  cschear
  • 61.4% (Friendly)
  • YAF Camper Topic Starter
2010-11-30T15:04:37Z
Thanks Mek - I'll give that a shot.

If that doesn't work I guess I could just load both, then have all the yaf javascript use 1.4.4 as outlined here .

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved