f0zzyNUE
  •  f0zzyNUE
  • 100% (Exalted)
  • YAF Commander Topic Starter
2010-11-18T10:17:47Z
hi,

i just updated my forum. unfortunately the "go to most recent post" links don't work anymore. they look o.k. in the sourcecode, but when clicking on the link the anchor is extended by %23postXXXX and therefore the anchor does not work.

e.g. my.forum.com/yaf_posts12345_test.aspx#post1234 is within the sourcode.
when clicking on the link it is replaced in the browser address bar by my.forum.com/yaf_posts12345_test.aspx#post1234%23post1234

so the link always leads to the first post instead the last post.

regards
CHris
Sponsor
f0zzyNUE
  •  f0zzyNUE
  • 100% (Exalted)
  • YAF Commander Topic Starter
2010-11-18T18:41:00Z
it looks like some javascript is modifying the URL address. as long as the page is loading the correct link is displayed. when it finished rendering the url gets the %23postXXXX appendix.

maybe it helps that i use the forum in german language context.
Ederon
2010-11-19T08:26:56Z
http://tracker.yetanothe.../IssueDetail.aspx?id=128 

Anyway, I suppose you meant you found it in 1.9.5, right? 🙂
When I post FP:Ederon in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting.
UserPostedImage 
f0zzyNUE
  •  f0zzyNUE
  • 100% (Exalted)
  • YAF Commander Topic Starter
2010-11-19T09:41:39Z
http://tracker.yetanothe.../IssueDetail.aspx?id=128 

Anyway, I suppose you meant you found it in 1.9.5, right? :)



yep. 1.9.5.RW like in the thread title :)

problem seems to be a javascript function
Sys.WebForms.PageRequestManager.getInstance().add_pageLoaded(loadGotoAnchor);
function loadGotoAnchor() {
               window.location = window.location + "#post6161"
}

i don't know where this code is produced, but window.location = window.location + "#post6161" upon client side onload event adds another anchor to the URL which is not necessary as the URL already contains an anchor.

HTH
CHris
Ederon
2010-11-19T10:13:39Z
I was asking because title says 1.9.95 :P

We shall look into it, thanks for heads up!
When I post FP:Ederon in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting.
UserPostedImage 
f0zzyNUE
  •  f0zzyNUE
  • 100% (Exalted)
  • YAF Commander Topic Starter
2010-11-20T10:47:06Z
Originally Posted by: Ederon 

I was asking because title says 1.9.95 :P


oops 😊

BTW, i fixed that issue in my installation. but another anchor glitch occurs. when adding attachments to a post and click on the "return to post" button the anchor does not contain the string "post" - so instead #post1234 the anchor is just #1234 which does not move the focus to the correct anchor. i don't know if that is a followup bug due to my simple bugfix.

the quick bugfix in file javascriptblocks.cs just returns an empty string for method public static string LoadGotoAnchor(string anchor)

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved