Underground
2010-11-03T19:44:07Z
It has been a while since I build YAF from the source (about 4 weeks ago or so).
Now, I know that the YAF developers don't keep a roadmap and thats ok, no problem.
But since I only have the express version, I have troubles building the YAF. I have to change projects etc to be able to actualy build it.
Due to this hassle, I would like to ask the developpers when the RC2 is about to be released (complete build checked in in sourceforge).
If that would be in a month or so, I will build it this weekend and put it on the test site. But if you think it will be in about two weeks, I will wait (not worth the trouble of editing the projects and so on. Takes about 1 hour)

I am very curious about the next two features:
- email notification on new posts (not working in RC1)
- mobile theme

Please let me know what the forecast is. Thanks in advance.

- Robert
My site containing the YAF forum: Globalcaching.eu 
Sponsor
Mek
  •  Mek
  • 100% (Exalted)
  • YAF Developer
2010-11-03T21:02:25Z
Sourceforge SVN dropped: http://forum.yetanotherf...-Subversion-Updated.aspx 

I would say two weeks is not an impossibility; but like all things it depends on how much the day job interferes which is why we shy away from hard and fast roadmaps with dates.

The best way to keep an eye out on how we are doing is to visit the BugTracker part of this site.

Don't shoot me if I'm wrong though :p

UserPostedImage 

"It's a case of RTFM.. the only problem being we don't have a manual!"

When I post FP:Mek in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting. (Yes I stole this off Ederon 🙂 )
cagliostro
2010-11-04T07:21:52Z
For now, i see RC2 just came online....


Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer
2010-11-04T17:32:44Z
Originally Posted by: cagliostro 

For now, i see RC2 just came online....


Hopefully all those issues you mentioned are fixed in RC2.
Underground
2010-11-06T09:21:12Z
Originally Posted by: Mek 

Sourceforge SVN dropped: http://forum.yetanotherf...-Subversion-Updated.aspx 

I would say two weeks is not an impossibility; but like all things it depends on how much the day job interferes which is why we shy away from hard and fast roadmaps with dates.

The best way to keep an eye out on how we are doing is to visit the BugTracker part of this site.

Don't shoot me if I'm wrong though :p


I thought that sourceforge was still used for the binary files?
But I already get the source from the new site for a while.

I won't shoot you! ;-)

The reason why I respond so late is due to the fact, that I couldn't respond earlier due to an exception if I tried to post a message here. But today I can...weird.
That is the reason why I haven't used the new binaries yet. But now I see that fixes are submitted to the repository and...yeah, it is a moving target LOL (is a very very good thing!)
So, I will build it this weekend myself (with the new source) and will ask our testers to test the forum.

Also, should the mobile theme on this site (so, this forum) work? Because when I access this forum with my Android device, I don't see a mobile theme, but the normal standard theme.
And for me to get it to work on my site, do I need to put something in app_browsers for that?

- Robert
My site containing the YAF forum: Globalcaching.eu 
Underground
2010-11-06T10:36:00Z
got it running on my site.
But how should the mobile theme work? Automatically detect and how?

By the way, I love the feature to change the time in 'time ago' instead of the UTC for guests. Great!
My site containing the YAF forum: Globalcaching.eu 
tha_watcha
2010-11-06T17:54:54Z
Quote:

But how should the mobile theme work? Automatically detect and how?



It should work now i sumitted the latest changes to Source Repository (Rev. 4064).

Guest Users


Logged In Users


The Url Parameter are Session based, if the user wants to permanently set one view there is an Option in UserCP -> Edit Profile-> Use Mobile Forum Theme (This Setting is only Visible when the User uses a Mobile Browser). This Setting can be overridden by the Url Parameters

There is also an Link at The Footer where you can Switch

Quote:

View Full Site | Powered by YAF 1.9.5 RC2 | YAF © 2003-2010, Yet Another Forum.NET



and

Quote:

View Mobile Site | Powered by YAF 1.9.5 RC2 | YAF © 2003-2010, Yet Another Forum.NET


UserPostedImage
Underground
2010-11-06T21:55:03Z
tha_watcha, does this mean that if user 'A' sets the theme to lets say 'BlueGrey' using his PC (so using a browser on his PC), that when he access the forum using his mobile, the theme will also be 'BlueGrey'?
And if so, is this the desired way to go?
I would suggest that the mobile theme should work independently from the user setting. Unlesss....unless, there will be a seperate setting for the user to set the theme when he accesses the forum with its mobile.

Like, now, I have set the theme in my profile to a 'normal' theme. But when I access the forum using my mobile, I expect it to switch to a mobile theme. But it doesn't.
My site containing the YAF forum: Globalcaching.eu 
tha_watcha
2010-11-07T07:21:38Z
Quote:

tha_watcha, does this mean that if user 'A' sets the theme to lets say 'BlueGrey' using his PC (so using a browser on his PC), that when he access the forum using his mobile, the theme will also be 'BlueGrey'?



No the user will see the Mobile Theme, if the Setting is enabled which is By Default Enabled.
UserPostedImage
Underground
2010-11-07T12:48:30Z
Originally Posted by: tha_watcha 

Quote:

tha_watcha, does this mean that if user 'A' sets the theme to lets say 'BlueGrey' using his PC (so using a browser on his PC), that when he access the forum using his mobile, the theme will also be 'BlueGrey'?



No the user will see the Mobile Theme, if the Setting is enabled which is By Default Enabled.


Ah, thanks.
In that case, I have a problem on my side, because when I access the forum with my mobile, I don't get the mobile theme. (Android using safari)

Setting it manually, I see I have another 'problem'. I have the forum running in a masterpage. This masterpage has a fixed with (defined stylesheet) and fixed image header (image above forum defined in stylesheet).
So, also if the mobile theme would work for me, I have to tacke that problem first.
It looks like I need to determine if the website is accessed by a mobile device and use other stylesheet. But how?

- Robert
My site containing the YAF forum: Globalcaching.eu 
tha_watcha
2010-11-07T14:04:04Z
Quote:

In that case, I have a problem on my side, because when I access the forum with my mobile, I don't get the mobile theme. (Android using safari)



Did you use the latest source code?

I tested it with Android Default Browser and it worked

Quote:

It looks like I need to determine if the website is accessed by a mobile device and use other stylesheet. But how?



You can use 2 css files

<link rel="stylesheet" type="text/css" href="mobile.css" media="handheld"/>

<link rel="stylesheet" type="text/css" href="screen.css" media="screen"/>

you can also define a special one for the iphone

<link media="only screen and (max-device-width: 480px)" href="iPhone.css" type="text/css" rel="stylesheet" />
UserPostedImage
Underground
2010-11-07T19:17:28Z
Originally Posted by: tha_watcha 

Quote:

In that case, I have a problem on my side, because when I access the forum with my mobile, I don't get the mobile theme. (Android using safari)



Did you use the latest source code?

I tested it with Android Default Browser and it worked

Quote:

It looks like I need to determine if the website is accessed by a mobile device and use other stylesheet. But how?



You can use 2 css files

<link rel="stylesheet" type="text/css" href="mobile.css" media="handheld"/>

<link rel="stylesheet" type="text/css" href="screen.css" media="screen"/>

you can also define a special one for the iphone

<link media="only screen and (max-device-width: 480px)" href="iPhone.css" type="text/css" rel="stylesheet" />


I did use the most recent version (at that time 😉.
I did a SVN update Saterday morning (nov 6)
But on the Android 2.1 and 1.6 it wasn't working.

media="handheld"?
Thats it? I didn't know there was a special tag for that. Great news! I will work on that.
Thanks

edit:
by the way. Accessing this forum with my mobile, it also doesn't show the mobile theme. (to be sure I tested it right now).
My site containing the YAF forum: Globalcaching.eu 
Users browsing this topic

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved