BWG
  •  BWG
  • 99.4% (Exalted)
  • YAF Lover Topic Starter
2019-03-28T16:30:15Z
Hi,

Since upgrading to YAF 2.2.4.15 the TinyMCE html editor no longer works. It is selected in the host settings but the bbcode editor appears to be loading instead. CKEditor (html) is working ok.

Can't see any obvious reason for this. I've tried copying across the Tinymce folder from the previous version of YAF but it still does not work.

Ideas?

Thanks

BWG
Sponsor
tha_watcha
2019-03-28T16:38:03Z
Originally Posted by: BWG 

Hi,

Since upgrading to YAF 2.2.4.15 the TinyMCE html editor no longer works. It is selected in the host settings but the bbcode editor appears to be loading instead. CKEditor (html) is working ok.

Can't see any obvious reason for this. I've tried copying across the Tinymce folder from the previous version of YAF but it still does not work.

Ideas?

Thanks

BWG



YAF reverts back to the Standard editor if the tinymce is not found. It looks for the file tinymce.min.js in the tiny_mce folder Scripts/tinymce/
UserPostedImage
BWG
  •  BWG
  • 99.4% (Exalted)
  • YAF Lover Topic Starter
2019-03-28T16:55:55Z
Originally Posted by: tha_watcha 

Originally Posted by: BWG 

Hi,

Since upgrading to YAF 2.2.4.15 the TinyMCE html editor no longer works. It is selected in the host settings but the bbcode editor appears to be loading instead. CKEditor (html) is working ok.

Can't see any obvious reason for this. I've tried copying across the Tinymce folder from the previous version of YAF but it still does not work.

Ideas?

Thanks

BWG



YAF reverts back to the Standard editor if the tinymce is not found. It looks for the file tinymce.min.js in the tiny_mce folder Scripts/tinymce/



The tinymce.min.js is in the correct folder. I am running YAF as a virtual application under the root website in IIS. Is it possible that is the reason why it can't resolve the path to the tiny_mce folder?

Edit: I've had chance to do some local debugging and can replicate on my dev machine.

1) In host set the editor to CKEditor (HTML)
2) Post a message

This causes the RegisterCKEditorCustomJS() method to fire

1) In host set the editor to TinyMCE (HTML)
2) Post a message

This does NOT cause the RegisterTinyMceCustomJS() to fire and so the editor is not setting

I don't yet know why this is happening.
BWG
  •  BWG
  • 99.4% (Exalted)
  • YAF Lover Topic Starter
2019-03-28T21:48:27Z
Got it!

I upgraded from an older version and the app.config was missing a YAF.FileRoot entry. Not sure why CKEditor (HTML) was working - perhaps the code uses YAF.AppRoot instead.
Users browsing this topic

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved